Support Website Contact Support Blog

Phantom 3 Advance - Grid Mission issues

I recently downloaded the capture app for IOS on my iPad Air 2. I have also recently updated the firmware for my DJI phantom 3 advanced.

Upon opening the Capture App, I select “GRID MISSION”, however there seems to be NO connection to the drone. The status bar located on the right of the screen which indicates battery level shows a “N/A” indication and once clocked on, shows “disconnected”. My receiver and drone status all are great along with GPS signal.

Would this require me to conduct “FREE FLIGHT MISSION”??? or any suggestions on how to repair the disconnection issue?

your assistance is greatly appreciated.

 

 

As I know the IOS app works only with Phantom 2 V+.

Im also an IOS beta user with the P3 as well. I havent tested it yet. But i will go outside right now with mine and try it out. Ill post my results

Well just sent it up. So i started with mission grid. Made my flight pattern, it showed my status that everything was good, then hit the launch button…Nothing happened. 

I tried resetting the controller and drone. Did the same steps - still nothing.

Then i switched to Free flight. Tried to us the CSC command - nothing. So i closed the Pix app. Launched my dji go app and connected. Hit the home button on my ipad to minimize the dji app and started the pixapp. Tried grid mission. Nothing again. Tried free flight and it allowed me to fire up the drone. I was prompted that the camera would take a pic every 5 meters the drone moves. Flew around for a bit. It started raining. So had to land. I went to view my mission and i have an error across the only 3 files in there - no P4D file.

Was really looking forward to using the app. I launched it from the actual capture app. Should i have launched it from test flight?

 

Hey Jason. Did u update your iPad and the new firmware available for the drone? I tested it today and it flew fine, took off and stuck the landing. The only issues were the camera angle, the altitude and the selection for quantity of images taken during the flight for better quality generation of the 3D. I will test again tomorrow 

No i didnt update the firmware. The app never indicated that there was a new one available. Ill head to the dji site and find it now then. I will try again in the morning. Im planning on heading out the lake superior to get the sun coming up over the lake!

The only firmware update i can find is the one released back in decemeber - v1.6.0040

Was there a newer one than that?

Hi all,

We are glad to announce the release of the long awaited version of iOS Pix4Dcapture that supports new drones including Phantom 3 and Inspire 1!

Here is the corresponding forum post: https://community.pix4d.com/t/4968
You will find details about the procedure if needed.

Best regards,

Hello: 

I have downloaded the newest Pix4D Capture app, and have my new Phantom 3 Advanced upgraded to the current levels. 

However, when I get to the final step I get an error that the Mission was not Uploaded to the Drone. I have the remote on, of course, and I have tried cycling (rebooting) everything and doing this multiple times. Same error. Please help - I am renting Pix4D Pro desktop and I need to finish this job. Thank you.

Kirk,

My best results so far have been from flying manually. Ive honestly only used the capture app twice now. My surveys are done out in the north. No wireless access, no internet ability in the field. 

What drone are you using to collect your pictures?

Im using the Phantom 3 Advanced

I have a new Phantom 3 Advanced as well. I am trying in an Urban Environment with 4G LTE connectivity and everything, still no go for loading the Mission. So, for me at least, It is not an Internet Connectivity issue.

If i were you, i would set my DJI App parameters for the drone to take a picture every 5 seconds. Then fly the drone manually over what you wish to 3d render.

It sounds like its just the image acquisition your having issues with?

Or are you well versed in Pix4d as well ?

Hi Jason and Kirk,

Sometimes it takes a bit long to send the mission details to the drone through DJI SDK (what allows the communication between the two). It could also be that the takeoff check list is not refreshed so the error remains and prevents you to start but the mission is indeed uploaded.

We would suggest to try the following:

  • Press Cancel in the takeoff checklist, and then Next again, it will refresh the status.
  • Cancel the mission, and slightly adjust the grid, e.g. the size, in order to force the app to upload the mission again.
  • Restart the mission, meaning close the app, disconnect the mobile device, switch off the remote controller and the drone.
  • Uninstall Pix4Dcapture and reinstall the app.

Let us know if it solves the problem.

Regards,