Support Website Contact Support Blog

Failure to load imported point cloud during step 3

My normal processing routine is to perform steps 1 and 2, then run a LAStools script that reduces noise and removes many pointsin flat areas on the densified point cloud. Then I import it back into Pix4D and then generate the mosaic. This drastically speeds up mosaic generation and in some cases makes it possible at all when I have clouds over 1 billion points. In my opinion the resultant mosaic is better too.

With the most recent update (2.1.49 64-bit), Pix4D fails, saying the cloud is empty. I have viewed the cloud in CloudCompare and it looks excellent, with about 175,000 points, down from 55 million in the original. I have also tried saving the cloud as a LAS instead of a LAZ but there is no difference.

As a work-around I am using the full cloud.

Let me know if you need any project data for troubleshooting.

I have exactly the same problem, I have a project with 2500 photos data set and when the software finished the step 2 I get the same message and the process stopped. I am losing time and money in my projects due to this issue, I am going crazy trying to get god results and my customers are angry. This is not fair for something you paid. Please, what can be done? How can I get the previous version.

Luis,

In your case you probably have too many points in your point cloud. I did a 2500 photo project earlier this year and had a little over 1 billion points, which Post Flight Terra 3D (the sensefly rebranded version of Pix4D) refused to load. I cleaned the cloud using LAStools and brought it down to 170 million points. Once loaded manually the mosaic was produced easily.

This method may not work now, though, as I have reported above.

Another option is to change densification options. Try image scale at Half Size and uncheck Multiscale. If that doesn’t work, change point density from optimal to Low (or High to Optimal, depending on where your settings are now.

I have a support ticket into Pix4D on this issue.

Luis/David

 

Did you have ant success with this issue as I am dealing with the same thing.

Dale

Thanks for reminding me about this.

I normally run my processing from a remote desktop and I needed to do some testing to ensure the remote desktop wasn’t the problem. I’m running Pix4D on my desktop right now as it happens and I tried loading a processed point cloud using the menu option and encountered the same problem.

Support told me to try dragging the point cloud from file manager into the layer tree while in the Ray Cloud editor, and then try step 3 processing again. I hadn’t actually tried it until just now and it does work.

So, Process > Import Point Cloud for DSM Generation is broken but there is a work-around.

Hi all,

The current version 2.1 has a known bug related to the generation of DSM using an external point cloud. 
This bug is fixed in version 2.2

We apologize for the inconvenience.

You can always download the previous version (2.0) : https://mapper.pix4d.com/download/

(click “Show previous versions of Pix4Dmapper” )

 

Best regards,