Support Website Contact Support Blog

Step 3 Fail - External Point Cloud

Hi,
I have used a separate software to clean a Pix4DMapper (v3.2.10) generated point cloud and wanted to complete the processing using this ‘external point cloud’.
I can load this LAS file, which aligns with the existing data, and I can choose ‘process external point cloud’, but each time I try to run step 3 it fails to load the point cloud. Following this Pix4DM reverts to only showing/listing the original point cloud.

Log details:

[Processing]: Substep Ortho load pcl started.
[Processing]: Load point cloud
[Info]: Load point cloud [0/0] elapsed 011ms …
[Info]: Load point cloud: mean = 498835 5.80377e+006 60.
[Info]: Load point cloud: range = [498619, 499042] x [5.80356e+006, 5.80398e+006] x [45.8762, 69.6092].
[Info]: Load point cloud: workspace = {x = [49857613269, 49909533405], y = [-580401430063, -580351069008], res = 3144, pixels = 16514 x 16018}.
[Info]: Load point cloud: loading external DSM <C:/AUAV Processing/20200624_WSC_Maffra/20200624_WSC_Maffra/2_densification/point_cloud/20200624_WSC_Maffra_group1_densified_point_cloud_edit_WGS84.las> …
[Error]: The external point cloud: <C:/AUAV Processing/20200624_WSC_Maffra/20200624_WSC_Maffra/2_densification/point_cloud/20200624_WSC_Maffra_group1_densified_point_cloud_edit_WGS84.las> is empty after loading! Stopping the processing!
[Error]: Load point cloud failed!
[Error]: >>>Load point cloud<<< failed with error (failed to run a step!)!
[Error]: >>>Load point cloud<<< failed with error (failed to run a step!)!
[Info]: OS Power Save: Enable
[Info]: >>>Step3<<< done in 08s:421ms / 0.14035 min

Any suggestions welcome.

Thanks
Paul

Hi,

The issue might be related to the not sufficient amount of RAM for the project.

Cloud you, please upload to our OneDrive your .log file? I’d help us analyse the problem.

Regards

Hi Beata,

I’ve uploaded the LOG file, however, it’s not RAM. This project is a small 22Ha site, this unit processed a 148 dual grid project last week.

Regards
Paul

Hi Paul,

Would it be possible for you to use unedited external point could? When I was investigating this issue, I realised that in 2016 one of our clients had precisely the same problem. At that time, this limitation was a known issue. Apparently, it was fixed in further releases of Pix4Dmapper. However, as your S&U expired, you can’t upgrade the software to the latest stable version. Therefore, you could try if unedited point cloud will work in Pix4Dmapper 3.2.10 or update the software.

Speaking about RAM, indeed, you have 64GB. However, only 19GB is available for the processing. Perhaps, the rest is in use by other programs.

Additionally, your NVIDIA graphics card doesn’t have the latest drivers. Please update your card by downloading the newest version here.

I hope it helps.

Regards

Hi Beata,
I’ve tried with much more free RAM and upgraded NVIDIA drivers and get the same result. Though using the original LAS external point cloud, it does work, but still not with the edited LAS.
I have uploaded the two LAS files and the updated LOG file to the OneDrive link above.
Thanks
Paul

Hi @Australian_UAV,

I forgot to add a line that the issue you’re experiencing is eventually not related to RAM or NVIDIA drivers. I’ve just wanted to clarify the RAM aspect and prevent your system from crashing by suggesting the NVIDIA update (for this or any future projects).

To summarize, there’re two solutions to your problem. The first one is to use unedited point cloud with Pix4Dmapper 3.2.10. The second is to upgrade the S&U so you can download the latest stable version 4.5.6 where I believe you’ll be able to import your cleaned point cloud. On order not to be vain in words, I can test your inputs so you won’t lose your money on something that won’t work. To do so, I’d need your images and .p4d file. I sent you an invitation to a personal OneDrive where you can store the data.

Let me know what you decide.

Regards

Thanks Beata,
I’ve looked further into the files and the edited file has a different format and will probably be why it’s not being loaded by Pix4DM. It loads fine into other software but it’s likely to be the cause. I’ll try the newer version of Pix4DM and see if it helps.
Thanks for your help.
Paul

1 Like

Hi Paul,

Thank you for your reply.

Please let us know if your issue is solved in the latest version of Pix4Dmapper.
Thanks!

Hi,
Have similar problem with orthomosaic generation (step 3) with external point cloud.
I’ve processed 9/10 projects sucessfully with that workflow and looks good. Unfortunately in one project I have problem with processing.
Log screenshot

Any ideas?

Thanks in advance!

Przemek

Hi Przemek,

Since you have a valid S&U, you’re entitled to personal support. Please submit a ticket directly to Pix4D Support and send us the .log file. We’ll investigate it. Thanks!