Support Website Contact Support Blog

Error importing marks

I try to import MTPs from pix4d mapper to the project. The exported text file from GCP/MTP manager, comes with 5 columns: image name, label, image coodinates and path (optional).
sample:

1_101_0038_0044.JPG,mtp1,3864.0039,539.1861,G:/images/1_101_0038
1_101_0038_0045.JPG,mtp1,4098.8542,3345.3524,G:/images/1_101_0038
1_101_0038_0077.JPG,mtp1,2219.8464,262.559,G:/images/1_101_0038
1_101_0038_0078.JPG,mtp1,2109.5743,840.9665,G:/images/1_101_0038
1_101_0038_0079.JPG,mtp1,2284.0199,799.1265,G:/images/1_101_0038

the file is loaded in ‘import marks’ section, but pix4dmatic doesn´t recognized the text file, with 1 column missing error.
I try changing the label column to the first, or adding the entire path to the image name.
Is a large file with 1800 rows, so mark them again is not an expected option.

refer: How to import GCP marks from PIX4Dmapper into PIXDmatic – Support

Hi,

Welcome to Pix4D Community.

Thank you for all the information provided.
The workflow you are following (How to import GCP marks from PIX4Dmapper into PIXDmatic – Support) refers to Ground Control points (GCPs) and is assuming all the labels to be GCPs.

PIX4Dmatic is expecting the format to be like this: Tie points (GCPs, CPs) import format – Support.

Make sure that the exported .csv file follows this format:

label, coordinate1 [decimal degrees], coordinate2 [decimal degrees], z [meter]

or

label, coordinate1 [units], coordinate2 [units], z [units]

Let me know if you need further support.

Cheers

Hi @oscar.paulsen,

Importing MTPs with their marks is not supported at the moment. We’re planning to add this functionality, so that it is easier to export MTPs from PIX4Dmatic and importing them again, as well as to import MTPs from PIX4Dmapper in case you would like to compare the reprojection error of MTPs on a given project between PIX4Dmapper and PIX4Dmatic, or if you need them for a tricky project that you want to run in both.

Here is an example format of what we currently export:

“fullpath”\Image_000274.jpg,MTP1,842.725,778.326,9.55114

However, at the moment this was built with GCPs and Checkpoints in mind only, which means that you would first need to have GCPs or Checkpoints in the project to be able to assign the marks to an existing GCP or Checkpoint. Directly importing marks results in the error you experienced.

If more people are interested by this feature, please add a comment or upvote the original post.
Thank you!

Pierangelo

Thanks!
I solved it by taking the MTPs as GCPs and then marking them in the project. It’s a long process but it worked.
I realized it’s not supported when i export the resulting marks y try to add them to the same project with different parameters.

nice workaround! glad you could make it work!

I’m realizing another workaround that could have worked:

  • Import a fake GCP file using the MTP labels and some arbitrary coordinates.
  • Import the MTP marks as GCP marks for the fake GCPs.
  • Change the tie point type of every fake GCP into MTP in the UI.
1 Like