Support Website Contact Support Blog

[Error]: Failed to write Exif!

o que fazer quando ocorre o erro

Hi, 

We saw this error a few times when users have cancelled processing. Restarting the computer might help. 

This also happened when there were some issues in the project itself, e.g. too low processing options. If you could describe in more details when the error occurs and if you could post a link to download the quality report and log file of the project we could help more. 

1 Like

Mr Pierangelo,

When we process the photos without the support points, pix4d generates all 3 steps.

But when we add the points of support (raised in the field several times and corrected) the error appears: Failed to write Exif at the end of step 3.

follows a link of the requested files:

https://we.tl/52AmZZ8xrX

 

Please, we need to identify what is happening, we have a lot of work to deliver.

awaiting return

 

Klauber Morací

obrigado

In the log file an [Info] message shows each time before the error message “Failed to write Exif!”: 

[Info]: Exif error: C:/Users/KM Topografia/Desktop/VOOS PHANTON 4/10 - outubro/13-10-17- Aterro Sanit�rio/Volume lixo 13-10-2017/3\_dsm\_ortho/1\_dsm/tiles/Volume lixo 13-10-2017\_dsm\_1\_1.tif11528: **Failed to rename file to** C:/Users/KM Topografia/Desktop/VOOS PHANTON 4/10 - outubro/13-10-17- Aterro Sanit�rio/Volume lixo 13-10-2017/3\_dsm\_ortho/1\_dsm/tiles/Volume lixo 13-10-2017\_dsm\_1\_1.tif: **No such file or directory (errno = 2)**

[Error]: Failed to write Exif!

The Info messages says  Failed to rename file to  and No such file or directory (errno = 2). There might be an issue in how the DSM was stored. 

I would try to save a copy of the project and try again by using Project > Save Project As and save it in another folder. 

What do you mean by points of support? Manual Tie Points (MTPs) or Ground Control Points (GCPs)? If you add them, make sure to Process > Reoptimize the project (this will erase all results that are already created for steps 2 and 3). 

Sr. Pierangelo

Bom Dia!

We did some testing following your guidelines, saving the project in another folder and processing again.

 

We had success with some projects and errors in most, always the exif error, I did a test with the template that comes in the pix4d itself and also appeared error exif. I asked to process again and after three attempts I was successful.

 

This is strange of the error, but after several attempts it succeeds.

 

Another thing I noticed that for larger areas 100 ha, always ERROR in 100% of the attempts.

 

Here is a link from a mining area that I am urgently in the delivery of and the project always fails.

 

https://we.tl/Ri4nevWO4q

 

I checked that it’s not GCP’s because I always go in with the land points and apply the Re-optimize and that’s not the cause of the error.

 

 I’ve made a couple of attempts here: I already uninstalled the pix4d and installed again, I already did a cleaning on my workstation.

 

The video card of the workstation is PNY Quadro K1200 4GB DDR5 VCQK1200DVI, can it be anything with the board?

I do not know what else to do and I have several projects to thank, please help me.

 

Thank you

 

Moraci KM

A new stable version, containing the fix for “Failed to write Exif”, was just released. Could you please try to run the project using the version 4.1.19 and let us know if you still encounter any issues. 

You can download the latest version here: https://cloud.pix4d.com/download/ 

Best,

1 Like

I just received this error with 4.1.19. Please advise alternate solutions.

@Kevin, we contacted you via support ticket.

I’m also getting the same error. Running on the latest 4.1.22. 

@Mitch, we are in contact with you via support ticket. 

On the last project, I was able to successfully process the project after a fresh reboot and running step 3 again.  I just had the issue come up again on a new project overnight.  I replied to the support ticket with all of the requested information.  

Is P4D having any luck pining down this issue and getting it patched?  It really causes workflow issues with you try and run long processes overnight only to wake up and find out it failed.

Kevin, I too was able to process once I re-saved the file to a different location, re-named the file to something basic without special characters or spaces (numbers and letters only), and used the default template. I then tried again using my own settings I need (1ft contouring, more dense PC) and it worked once again. I then tried a different project and it failed. I tried doing the same as before, with one twist: I made sure my images and Pix4D files were on the same drive. 

We use a server for everything and try to keep everything on it. The plot of land I’m working on is 100+ acres, so I left the images on the server and ran the Pix4D files on my SSD. Since the location issue is the only common denominator I’ve been able to discover, I’m almost positive that’s the issue.

I don’t know why this issue is a thing, especially since I’m only referencing the EXIF data initially and using GCPs before processing step 2&3, so you’d think that information would be useless to the process. Hope this helps some.

I am still having this issue on EVERY project now. I have a support case where I provided extensive data to P4D, but they have not replied in a week. I have always run the photos on a local SSD rather than a network so I don’t see that being the issue. Latest project I did a preemptive reboot before processing steps 2 and 3 and it still failed.

I’m at a loss, but this is catastrophic to workflow and ability to get any production out of this software. I need a solution now as well as some additional time on my monthly license for having to do things twice to four times before it will work.

@Kevin, we understand the frustration and are working on resolving the issue.

At the moment you can try to process Step 3. again after disabling “Merge Tiles” option in processing options for Step 3…

You can merge the tile later on using this article: https://support.pix4d.com/hc/en-us/articles/202559539.

Best,

The “merge tiles” solution worked on 1 job that had successfully failed a half dozen times before.  It had no effect on a 2nd project that fails to process step 3, so I don’t know if the first was a fluke or actually related to “merge tiles”.  In the end, i’m still out of business until this is fixed. 

Blaž, Is there a prior version I can downgrade to in order to get back working again?

1 Like

@Kevin,

Thank you for trying it out. There were also some other users reporting that the proposed workaround does not solve the issue. 

There is a high chance that the issue is related to a specific device and therefore downgrading the software version would probably not fix the issue.

I ran a project from Kevin a total of 3 times and had zero errors…a few warning messages but not this EXIF problem.

While it was only 1 project, I feel it isn’t a general software bug but must be something to do with hardware.  From my general computer experience outside of Pix4D, this seems just like other flaky hardware that I have seen right before failure.

Easy now. While I appreciate your efforts, they are not enough to say this isn’t a software issue and suggest a diagnosis of failing hardware. I ran this and other troublesome projects on two different systems with the same outcome (one being a nearly brand new 8-core Xeon with 64 FB Ram), you did not process it with my GCP’s, and I am not even close to the only one having this problem.

I became a surveyor late I life and spent most of my life in IT. The failing hardware diagnosis is way off the mark. Especially when all the facts are taken into account. It could be a software bug with certain hardware, but the hardware itself.

2 Likes

Yes Pix4D has had and very well could still have some issues with some specific pieces of hardware in their coding. I have spent decades building and working on computers too and like I said, it is a feeling…most likely RAM chip. None of the evidence is conclusive or you would have fixed it before even posting here. A large coding bug would be a more widespread and consistent problem, like the GCP coordinate change issue, so the inconsistency points me to a flaky piece of hardware. Of course seeing the issue across a few different computers doesn’t make that a certainty but one of the places to start since my setup has zero issues. Lastly, it could be from a conflict with another piece of software that may be inconsistent as well. I am not defending Pix4D but we all know that until an issue is consistent and reproducible then a coding solution isn’t normally found.

1 Like