Support Website Contact Support Blog

DTM removing hills peaks

Hello,

In the pictures you can see the same area as DSM and then as DTM after creating DTM in Pix4D.

As you can see, there are areas (hills peaks) that were trimmed in the DTM even though they should not be trimmed. 

Any suggestions how to fine-tune the results so the DTM would remove only structures and vegetation and not those hills peaks?

Thanks

 

 

Hi Rami, 

This is a limitation of the algorithm we currently use to create the DTM, which sometimes confuses hill peaks with buildings, because of the similar pointy shape. There will be two improvements in the future: the algorithm will be improved with a better classification (less mismatches) and it will be possible to edit these results in the rayCloud. 

In the meantime, a solution might be to reduce the resolution (larger number) at which the DTM is generated: 


Let us know if that helped!

Hello,

Having the same problem with hill tops and other natural ‘blocky’ features taken out of the contour file. The points are still in the DSM, so I just do a close-knit grid DSM (100 or 250) and get the contours in another software package. I read that the contour can be created from the DSM, I think, but not sure how this is done, I think my contours keep getting produced from the DTM. The snap shots below show the options page. Can you tell me what I need to adjust to produce contours from the grid DSM, as the Contour lines option states 'lines are generated from the DTM.

Any help would be appreciated, thanks.

Regards,

Peter

 

 

 

Hi Peter, 

To generate the contour lines based on the DSM, you need to unselect the DTM generation, i.e. uncheck the box in the section 3.DSM, Orthomosaic and Index > Additional Outputs > Raster DTM > GeoTIFF.