DSM shows high vegetation in the contours file.

DSM shows high vegetation in the contours file. Looking at the point cloud the vegetation is classified correctly but it’s still showing up in the contours file.

Seems to remove some but not all any guidance would be appreciated.

Hi @joe.gatti,

Thank you for your question and welcome to the Pix4D Community :slight_smile:.

Yes, the contour lines are taking into account the Digital Surface Model (DSM) if no Digital Terrain Model (DTM) is generated. You need to enable the DTM generation as only the Ground and Road Surface groups are preserved in the DTM.

You can find additional information here:

Happy mapping!

Hi Daniele,
Thanks for the response. I have those setting checked in option 3, see below.

Am I missing something?

I did watch the video on that link just so you know.

I’m running version 4.8.0 if that makes any difference.


Hi @joe.gatti

Thank you for your reply.
Could you please open your DTM to see if it shows the vegetation?
(click Mosaic Editor on the left sidebar > Select DTM in the droplist at the top of the PIX4Dmapper window) The DTM will appear with a color scale.

You can also try to use a different Surface Smoothing in the DSM Filters.

Also, did you enable Point Cloud Classification in step 2?

Hi @Daniele_Lecci
Yes I do have classify point cloud checked. The DSM and DTM both look pretty good to me see below.



I’ll try changing the filter and see if that does any good.

Thanks again for the help.

Hi @joe.gatti,

Thank you for the screenshot.

Yes, the DTM looks smoother than the DSM, but part of the vegetation is still visible (image below)

Only the Ground and Road Surface groups are preserved in the DTM. To improve the DTM, all the terrain points should be assigned to one of these point groups. To manually move points between the automatically generated point groups, the Edit Densified Point Cloud option can be used: How to edit the point cloud in the rayCloud. If the point cloud classification has not been generated, which is not recommended, all the points are treated as non-terrain points and the DTM is a smoothed version of the DSM.

You can find additional information here:

Hi @Daniele_Lecci,
I’ll give that a try and let you know how it goes.

Thanks again.

Hi @Daniele_Lecci
I tried editing the point cloud to make sure everything was assigned to the correct category but still get the same results in my contours file. Here’s another example.

Point Cloud:




Processing settings:

What am I doing wrong? The contours file would be great if I could get rid of the tress and man made stuff and it’s a lot cleaner than the contours file that come out of Drone Deploy but until I can get this resolved I’ll have to use the Drone deploy one when there’s high vegetation on the sites I’m flying.
Any help would be greatly appreciated.

Thank you for all the new information, @joe.gatti.

Please try to assign the points belonging to vegetation and buildings to the “disabled” group and process the DTM again.

In fact, the DTM interpolation:

  • Takes into account all of the points in the densified point cloud except points that you assign to the Disabled point class.
  • Applies little to no smoothing to points that you assign to the Ground or Road Surface point class.
  • Applies smoothing to points that you assign to the Unclassified, High Vegetation, Building, Human-Made Objects, or any other point class.

You can find additional information here:

Hi @Daniele_Lecci,
I don’t suppose there’s a easy way to do that…like click on the points classified as high vegetation and disable them all at once? Or I have to manually outline each thing and disable it? If that’s the case it seems like it would be a waste of time classifying the point and generating the DTM automatically in the processing option.
Thanks again for the help.

Hi @joe.gatti,

When you open the legend of the different classes, you can turn on/off selected classes.

Select only the High Vegetation, Building, and Human Made Object classes.

Assign the points belonging to these classes to the Disabled goup:

  1. Select the Edit Densified Point cloud tool.
  2. Draw a polygon in order to select all the points
  3. Select the Disabled class
  4. Assign the selected point to the Disabled class

Now you can create your DTM and contours.
Please let us know how it goes.

Hi @Daniele_Lecci ,
Ok, that looks much better. Still need to do a little tweaking but that will do the trick.
Thanks much.

1 Like

Hi @joe.gatti,

I’m happy to hear that you are getting good results.

Happy Mapping!