Support Website Contact Support Blog

DJI SDK failed to initialize:Attempt to invoke method 'void object dji.internal.f.b.b()' on a null reference object

I have a new Phantom 3 Standard and tried to use Pix4DCapture and got that error.  I see a post where you’re working on it.  When will it be fixed?  I also tried Dronedeploy and it connected to the drone with no problem!  Now Pix4D…which one should do you think I should buy?

Hi Bill

Can you reboot your device but do not start DJI Go app, just start Pxi4d Ctl+ app, and Pix4d capture app and see if that helps.

It wasn’t the DJI Go app…I did a forced stop on that.

Hello… I have the same problem.

I have a phantom 3 4K and a phantom 3 standard… and the both show the same message.

DJI go is not runing in my tablet…

I thank your help…

regards.

Hi,

We believe that the issue is related to DJI SDK and can happen in some cases. Make sure that you have the latest version of the app which supports the latest SDK. There is a community post where this topic is already mentioned: 207475343

At the moment we advise to make sure that you have internet connection when you try to connect to the drone if you receive the warning. After that you should not receive the warning again and it should not be necessary to have the internet connection everytime you want to connect to the drone. If this does not work, close the app and unplug/plug the micro-usb cable on the controller and device and try again.

 

I have done every possible scenario and get the error still. I use a Phantom 4 pro and a Samsung S7 edge on my controller. Worked fine with DJI GO4, Litchi, and drone-deploy but really want to use Pix4D

Hi Jeremy,

We recommend to read this article to troubleshoot app issues and proceed with basic checks:

Please use the main thread to comment on these issue:
(Android) DJI SDK failed to initialize […] void.dji.internal.f.b.b()