Support Website Contact Support Blog

SDK error when opening the app

El programa Pid4dcapture me tira este error al iniciar:
DJI SDK failed to initialize. Native method not found:
Dji.midware.natives.SDKRelative.JNI.native_getUsbA ccesoryAttachedString()Ljava/lang/String;

Hi Juan,

The SDK is a library from DJI that our application uses to write commands to the drone such as start the rotors, take images, etc. When you launch the application the first time or after an update it is need to be connected to internet so that the application can get the DJI SDK token. Once the token is acquired, it is no longer needed to be connected to internet when you launch the application. However this message may also appear once in a while to get the SDK token but we do not know exactly how regularly.

To get the SDK token, make sure that you are connected to the Internet. If you do not have the SDK token you will not be able to connect to the drone and to perform the mission. For more information:



I am having a similar issue. My SDK error states that it needs to be connected to the internet, even though it already is connected. I have tried 2 different wifi and neither worked



Hi Mark,

Could you please try the following instructions:

  • Force quit Pix4Dcapture. (log out from the app).
  • Restart your phone.
  • Connect to the internet using the WiFi of your phone.
    - Open drone manufacturer app and check that everything is updated.
  • Quit the drone manufacturer app and open Pix4Dcapture.

Do not forget that, depending on your drone,  plugin are necessary if using Android version of Pix4Dcapture (ctrl+DJI, ctrl+parrot, …)

Is it solving the issue?