Support Website Contact Support Blog

DJI Controller - Mavic 2 Pro - Pix4D No Connection

I simply connected the drone and the smart controller to the computer using the mini usb cable
and used the latest DJI assistant to update both.
I then simply pasted the apk for PIX4D v4.7 to the smart controller and intalled over previous version.
I did not update Cntrl DJI and do not seem to need it to run Pix4D Capture

Did some test flights and it works perfectly

Hi all,

I have installed latest firmware by DJI assistant 2, using SD card I have installed CTRL+DJI ver. 1.9.9 and Pix4D ver. 4.8.0 to my SC. I have connected to my Mavic 2 Pro. Seems that everything works properly. The only problem is video feed. It works only the first time when tap the screen option. When I go to map and then back to screen then is black window. Any idea ?

I do not see any difference between CTRL+DJI 1.9.7 and 1.9.9. Both versions work the same and both have problem with video feed.

Hi
Is anyone else having problems with Capture not enabling auto focus and auto exposure?
Shot 5 missions on Monday and then realized when processing that the photo’s are all grainy and out of focus!
Thousands of photos that are garbage.
Is there a way to verify that AF and AE are enabled while in mission?
Note; this is while using Capture in Smart Controller and Mavic2 Pro.
Have also had a few issues with Capture disconnecting while in mission and needing to be restarted, but mission continues normally, as the mission is loaded in the drone.

Need to get this working, Using the smart controller I can now use the drone for hours at a time as the controller can charge while in use using usb charger and with the 4 bay DJI charger I am able to keep the 5 batteries in constant rotation.

I have verified that AF and AE are enabled in DJI GO4 and all software is up to date.

Hello,

We are aware of some issues with the image focus when flying the DJI Mavic Pro. These issues seem to happen randomly as no clear pattern was identified so far. At the moment we recommend to try the procedure below. Developers are looking to find a solution so that it can be fixed in a future release.

Recommendations :

  1. Setup the focusing action to C1/C2 of the remote controller (prior to the flight, in DJI GO).
  2. Fly the drone to the first waypoint and press C1/C2 to focus using DJI GO.
  3. Quit DJI GO app and Start the mission in Pix4Dcapture.

Regards,

Hi Kapil ,and every one else who is having problems with focus and exposure with Mavic 2 Pro.
There is a long list of people with this problem in another thread.
Today I re shot a survey I did on Monday.
I tried a different tack.
I started in DJI GO and focused to distant object and locked the exposure at 200 and set focus to manual, locking the focus.
I then switched the program directly to Pix4D Capture without going through Ctrl+DJI .
It seems that if the Smart Controller is already connected to the drone there is no need to run through Ctrl+DJI!
In Pix4D, I started the mission as normal on the ground and let the software complete the mission autonomously without any issues.
Photo’s appear very high definition when downloaded directly from Drone with micro USB cable. I tried to follow the above directions, but could not restart Pix4D and admit it is a little disconcerting dissconecting from the software while in the air.
I am using the smart controller with the latest and most current software for both the smart controller, the drone and Pix4D
I hope this helps all the other users of the Mavic2 Pro

Jeff