Support Website Contact Support Blog

Android USB bricked after pix4d capture installed (Mavic 2 Zoom)

I attempted to install Pix4D today with a trial and found that the Android “ctrl+dji” app did not list the Mavic 2 Zoom. Assuming they were not that different, I thought I would try the Mavic 2 Pro option and immediately I began to have connectivity issues. Remote Control would work for 5-10 seconds then lose connection with the Mavic. I assumed it was a Pix4D issue and a google search showed the Zoom is not yet supported. I uninstalled Pix4D and tried to use Litchi and then DJI Go app, both were unable to connect to the drone.

I did the typical restart everything, clear data/cache on everything, take a deep breath and even a new USB cable from android device to remote. Still no joy. As a test, the remote and drone had no connectivity issues when not connected to the Android device. I used a second android device with no problem, then installed Pix4D and went through the same process to see if this recreated the issue.[

It did. Neither of these Android devices can now connect to the remote controller. The common nexus is Pix4D. The software is uninstalled, but the difficulty connecting USB remains. At this point, the USB quickly connects/disconnects on the Android tablet (samsung galaxy s3 tab) and completely doesn’t connect to the Pixel 2. These devices worked perfectly prior to Pix4D.

I am looking for assistance getting my drone operational again and am hoping Pix4D will immediately remedy the issue before it starts to cause issues for others.

Thanks!

Bryan

Hi,

The Mavic 2 Zoom is currently not supported by our application and then you won’t be able to fly any missions with this drone using Pix4Dcapture.
It is currently not in our pipeline to support this drone. However, I will share your interest with the developer’s team so that they consider to implement the Mavic 2 Zoom support in the future.

Best,