Support Website Contact Support Blog

Chinese satellite map BUG

If the dataset is shot in China the MAP VIEW shows it with a mistake of several hundred meters. However, simple map shows the location just right. It is a bit awkward selecting the point cloud densification area as a simple map has little detail.
(on a sidenote, the satelite imagery is not up to par with Google Earth. (( althou that is not a big deal)
If anyone from Pix4d reads it,

  1. Is Pix4d aware of the bug?
  2. Is it fixable?
  3. Are there any plans to fix it?
  4. is there any work around now?

Hello Dennis,

Regarding your questions:

  1. Is Pix4d aware of the bug?
    Yes, we are aware that our satellite maps provider (Nokia here) is not as accurate in all parts of the world.

  2. Is it fixable?
    Yes, see below

  3. Are there any plans to fix it?
    Yes, we have plans in the near future to allow more background maps provider (google maps, bing maps, mapbox)

  4. is there any work around now?
    Yes, you can create a polygon in Google Earth (or globalmapper), export it as a KML, and import it in Pix4Dmapper.

Regards,

I love your answers. Straight and to the point.

I got the KML imported from Google Earth. It worked well.
Here is a step by step if anyone cares:
I made a polygon in Google Earth representing the future Point Cloud Densification Area. Then right clicked on it and Saved As… Chose KML as an option. Then in Pix4d in Point Cloud Densification selected “import”.
That gave me the exact polygon from Google Earth into Pix4d.
It didn’t fix the satellite map bug. However, I got my PCDA positioned precisely.

Huge Thanks!!!