Support Website Contact Support Blog

Capture App with DJI Inspire Pro - Exchange of Experience

For a few weeks now I’m trying to use my i1 Pro with Pix4D Capture app. As we all know it is not officially supported yet, however, it works “somehow”. This post shall serve as a knowledge exchange hub for all i1 Pro pilots. If the thread gets too exhaustive, we have to split it up, of course.

Thanks for participating. 

The only difference between the Inspire 1 (V2) and the Inspire 1 Pro, as far as I’m aware of, is the camera. While the “normal” I1 comes with a 1" camera (Zenmuse X3), the I1 Pro features a micro four-third camera (Zenmuse X5) with interchangeable lenses.

The impact on how the aircraft works with Capture app might therefore be limited, however, the different footprint of the cam with different lenses definitely does have some impact on overlap and flight plan, that’s for sure.

Also I realized that DJI releases different firmware versions/kits for the two aircraft types. This also might have some influence on compatibility with 3rd-party apps like Pix4D Capture.

Could not fetch media list from the drone! Try to restart it…

One strange behavior I have approached more than once, is this error message, appearing after a timeout when trying to “Start”. After pressing the [Start] button followed by “Next”, the app tries to connect to the drone. It might then somehow access the drone/camera’s file system in order to write the mission file, maybe I’m wrong. 

However, it seems that this error message can be ignored, correct?

Test Mission Failed

I just tried to conduct a test mission but failed, most probably due to version issues. DJI GO reminds me to update the firmware but 2 or 3 days ago there was no update for the PRO yet, so I denied (still running 1.1.0.40). 

However, without being aware of it, Capture was updated from 2.0.7 to 2.0.8. Now it’s well possible that the two parties are not fully compatible anymore. Since PRO version 1.2.0.50 became available as of yesterday, I can now give it a try.

BTW, in case of issues, look at the logfile Capture produces (located in Picture folder). It is a big help in understanding what’s going on. 

 

 

 

 

@Reto

FYI, DJI GO checks for the firmware of remote controller only.

Thanks for the hint!

While I upgraded the firmware of the RC, aircraft and camera, DJI GO 2.4.3 was automatically installed :-(. Ever since I was’t able to reconnect again. DJI GO 2.4.2 on iOS still works fine…

The current firmware and app updates, almost on a daily base, are a real nightmare, IMHO. At least it forced me to disable automatic app updates in Google Play Store, unfortunately too late, as it shows. 

No idea why the new GO app doesn’t connect anymore, any hint welcome.

Did you use an iOS device for updating firmware?

No, I updated through Android.
For me it’s pretty fuzzy how/when the RC gets updated, I guess it is DJI GO which does that. 

I downgraded  DJI GO meanwhile, to 2.4.2. However, I cannot establish a stable connection between the RC and the app running on Android. I have no idea what is/was going on. It’s really confusing.

Today I performed two more test missions with Pix4D Capture 2.0.8, after updating my I1 Pro firmware to the most recent version.
Result: NO SUCCESS.

Steps:

  1. all TAKEOFF CHECKLIST items validated (appear with green markers)
  2. manual takeoff in “P” mode, aircraft lifts off
  3. about 5m height, switching to “F” mode
  4. pressing green button for 3 seconds, drone symbol moves up – but I1 stays where it is, NO REACTION
  5. after waiting for about 20 seconds, I switch back to “P” and abort the mission

If I look at the log file, comparing it with successful missions conducted under v 2.0.7, I’ missing the following log entries:

>>> [D] [FlightControlDJI_P3_I1] New mission mode: Navi_Mode_Waypoint
>>> [I] [FlightControlDJI_P3_I1] Going to waypoint 0 (state: MISSION_STARTING)

It seems as if the “Grid mission starts” event does not have any effect…
No idea, what this means.

I will now try to downgrade Pix4D Capture to 2.0.7 – with this version I was able to conduct two successful grid missions.

Any hints very welcome!

You might need to downgrade your RC with SD card too.

New Test Mission with Capture 2.0.7 - still NO SUCCESS

I finally managed to install a Pix4D Capture app v 2.0.7, but still no success. 

It’s always the same, I can setup a mission, everything looks green/fine, I takeoff, switch to “F”, press the magic button for 3 secs but the only thing which moves is the small drone icon. No waypoint flying whatsoever.

If nobody knows better, I probably have to downgrade everything, borrow the Nexus phone I used for the first test missions and give it one more try. 

Reading the manuals once again, I realize that the RC is NOT updated via DJI GO. One has to plug-in a USB-Stick with the installation file, the same the aircraft uses.

Maybe my RC is out-of-sync with the aircraft, although I don’t get any hints and although I can properly fly it in manual modes …
I will definitely double-check this.

According to DJI, it is not possible to downgrade the RC - I’m confused.
But that’s also what I see. My RC version remains on 1.5.70, whatever I do. 

Is there anybody out there who conducts successful Capture missions, running his RC under 1.5.70?

‘Only the INSPIRE 1 remote controller firmware v1.3.00 or PHANTOM 3 Professional or Advanced remote controller firmware v1.3.20 or later support updating through the DJI GO app.’

 

From DJI, http://dl.djicdn.com/downloads/inspire_1/en/Firmware_Update_Guide_en_v1.4.pdf

Regarding downgrade, you are right. Just checked with DJI support. It’s infeasible.

Thanks a lot for your valuable input.

My RC currently runs under 1.5.70 but I would like to downgrade it to be compatible with the v1.1.0.40 firmware kit.

Do you know which RC version that is?
Do you know how to downgrade the RC?

I think I finally found out what the problem was. As supposed, it has nothing to do with the “Pro” flavor of my Inspire 1.

After setup, I usually started the mission while the aircraft was still on the ground. When the screen with all the check marks appeared, I briefly switched to “F”, to allow the mission to be uploaded. Before liftoff, I then switched back to “P”, launched and, after being airborne, switched back to “F”, followed by pressing the green button for 3 secs. With no effect, as we know.

Today, I tried to NOT SWITCH TO F while on the ground. This time, the mission wasn’t uploaded until airborne. Once in “F”-mode, after pressing the button, the I1 Pro finally started the mission, “as advertised”. The different app and firmware versions seem to have no effect on this issue.

Now that I know this little detail, I can of course avoid it. However, from a user point of view it doesn’t seem very obvious that a mission cannot be started, if the pilot switched to “F” beforehand. Since all the check marks appear OK, one doesn’t expect the mission to fail, i.e., to not start at all.

Capture keeps on crashing

The goal of today’s mission was testing my new Olympus 12mm lens for mapping missions. But to be honest, I’m pretty disappointed.

First of all, Capture crashed many, many times; during missions setup, after mission setup and even after completing a mission. Even worse, after crashing, it restarts immediately but never was able to reconnect to the RC / aircraft controller. It took me many manual stops and starts until I finally could take off.

Next problem: mission upload. Took me at least 10 times until I managed to successfully upload a mission, no idea why. Capture also doesn’t allow to retry uploading, you have to cancel and restart the mission (while aircraft is in flight and uses battery). Also the telemetry data (e.g. #satellites) comes and goes. The telemetry link works well with GO (under iOS), but not with Capture.

After many attempts, I finally managed to conduct a mission, but as it turns out, the forward lap is far away from 90% (only about 75%, with a wide-angle 12mm lens). The single images are usable but need to be adjusted image by image, too many issues with color temperature, etc… And, last but not least, while most pictures are taken with a speed of 1/400 and look pretty good, two pictures look completely black. The camera or Capture decided to choose 1/5700 and 1/8000 for just two images, although the landscape and lighting is exactly the same as in the last image.

Bottom line: My Inspire 1 Pro is not usable for mapping missions, not at all. I will have to carefully consider whether to sell it or to keep, waiting for improvements here and there.

Noone out there,. trying to use Inspire 1 Pro for mapping?

I purchased an Inspire 1 Pro a couple of weeks ago and went to do some mapping to market to an engineering firm here. It performed exactly like Roto stated. On the ground, all green check marks, hit start mission. Bird flies directly upward to correct altitude, but waypoint flying never starts.

I figured out that I had the capture app still looking for my Phantom 3 Pro. Once I switch to Inspire 1, it worked like a champ.