Support Website Contact Support Blog

Cannot Open Project on Desktop (4.1.24) after downloading from Cloud project

Having an issue trying to open project that I originally processed on Pix4D Cloud.

I tried the step of renaming the _cloud file to something else (as stated in another help topic) to no avail.

When I open the newly renamed file and path to my images (that I also downloaded) it just opens a project with no point cloud, ortho, cameras, etc. It creates a new Folder with basically empty project contents.

Whenever I rename the _cloud file to match the folder name with the actual project contents (DSM, DTM, Point Cloud, Mesh, etc) I get the ‘file too small’ error.

 

Not sure what I am doing wrong but it seems like when you export to Pix4d Desktop from the cloud, it should be a simple ‘open the project and continue working’

 

Here is where we start…

After Extraction we have this project folder…

Then, rename the cloud file (which then has to be a DIFFERENT name than the other .p4d (If I rename the original, to have the _ cloud match the name of the FOLDER, I get the ‘file too small’ error

Step 4

now to try the (2) file in Pix4d, its an empty file, just showing the picture locations in Map View… creates new folder (Untitled-261111 (2) with none of the project files in it (they are still in Untitled-261111 Folder)

 

 

My question is, how to we get the .P4D file to reference all of the project data (DSM, DTM, Point Cloud, Mesh, Cameras, etc) WITHOUT getting the ‘file too small’ error. 

 

What am I doing wrong here?!?!

 

Thanks!

 

Hey Joshua,

I would first suggest to download and install the latest software version 4.2.25 (click here). Pix4D Cloud runs that version. Then try to open the .p4d file (not .p4d_cloud). Let me know how it goes.

Exactly the same result. Says ‘file too small’ using the normal .P4D file. When I use the renamed _cloud file, just opens up a blank project, obviously. 

Any suggestions? I have tried 3 or 4 times, using the new software and the same result every time.

 

If I rename EITHER file, it just opens up a blank project with the image locations in the map… nothing under ray view.

 

If I make sure the file name (_cloud or not) match the folder name, I get the FILE TOO SMALL error…

Hi Joshua,

I have opened your project successfully on my side. I used the “raw” .p4d file (that can be found in the folder containing the images of the projects when you download the inputs).

I have uploaded the .p4d file here: https://we.tl/Mk65jHbhct. With this .p4d file, I managed to load all the results. Let me know if it is not working.

I tried the “raw” .p4d file that is in the folder with the images and get the same result. No cameras, no cloud, etc. Also tried the .p4d file that you uploaded. 

It looks like the project folder containing all the results is not detected. Could you ensure the project file (.p4d) and project folder are one below the other in the same directory?

I made it so they are one below each other and that doesn’t change anything. I get the file too small error message. 

I would like to send you the project result folders and file (p4d) I successfully opened on my side. Would you like me to share a link here (public)? If not, please open a support request so I can send it privately.

I opened a support request.

Your file opened and I was able to load the point cloud. Couple things I see are that the ground control is not present and the project is in meters. Maybe this is just the project I uploaded (March16th) with pictures only didn’t go through the desktop at all. The project uploaded on March 29th was from the desktop with ground control and correct project coordinates. 

As of now with the current updates can you process step 1 add GCPs on the desktop, upload to the cloud to process fully, and then download with the GCPs and project coordinates in tact? Or does the cloud not use the GCPs or other processing options that are set on the desktop?  

Hi Pix4D users,

If you are facing a similar problem that your rayCloud remains empty and you got the error “Failed to read cameras” please go to the post Pix4Dmapper Pro 4.2.27 Cloud to Desktop: Error Failed to Read Cameras where you can find a solution.

Cheers!