Support Website Contact Support Blog

Base Map for Pix4D Capture

We tried to do autonomous flight plan for aerial mapping of small islands
in the south pacific using pix4D capture but can’t locate the Area Of Interest (AOI)
on the current base map. Is there any plan to update this base map?

Hello,

Thank you for contacting Pix4D Support. The issue is related to the basemap provider.In Pix4Dcapture, the default Basemap provider is MapBox. Indeed, in some places, you may experience missing tiles/low resolution while using the map or satellite view depending on the zoom level. It can be possible to zoom but no tile is displayed or the zoom level is blocked. Unfortunately, only the base map provider is responsible for that.

Switching from the satellite to the map view might partially solve the problem of the missing background information/other issue when adjusting your grid in Pix4Dcapture.

Note

It may also come from the fact that some countries intentionally downgrade the resolution of the basemap provider for political reasons.

Workarounds:

  • Change the street or/and satellite basemap provider. In Pix4Dcapture, go to Settings > Map. You will have the choice to set several other basemap providers.

Change Basemap provider or add a custom one

  • Set a custom map provider like Google Maps. This community post and this comment describe how to proceed.
  • Import a .kmz/.kml file for the Android version of Pix4Dcatpure

Have you tried the URL that has been suggested in my previous comment to set google map as a basemap provider? You can enter below URL to load the google map in Pix4Dcapture:

http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=Ga

Regards,

Thanks