Support Website Contact Support Blog

Pix4Dcapture can't load a map

Hello! I’m getting acquainted with the application now! I downloaded the app and want to do a trial job. My first question would be that I can only plan a route plan near the site? My other question is why does black and white and outdated space appear in the app? There are buildings that exist in life, but it is not on the map. Thanks!

Have a look at this topic

If I start the Pix4Dcapture and will plan a mission, I can’t see any maps or satellite views.

It’ s possible to create missions but without seeing where I am.

I tried to de- and reinstall the app on the DJI Phantom 4 controler but it’s not working again.

What can I do?

I am having the same issue. Intermittent street but no satellite maps all of a sudden.

Hi All,

Pix4Dcapture uses Mapbox as a basemap provider. Mapbox has shut down its Legacy Static tiles API as of November 1st, 2020. Hence, the current and previous version, which uses the older API might have issues with the basemap.


  1. Update the software to the latest version of Pix4Dcapture.
  2. Change the street or/and satellite basemap provider. In Pix4Dcapture, go to Settings > Map. You will have the choice to set several other basemap providers. Change Basemap provider or add a custom one
  3. Set a custom map provider like Google Maps. This community post and this comment describe how to proceed.


The base map is not loading.
Internet connection is active.
I have tried the USGS base maps. No luck.


Pix4d 4.5.0 build 2421

CrystalSky 5.5

Hi. I use Pix4D capture for mission planing for almost a year. Until last two days, it used to run perfectly, but now it can’t load a map. It crushes when I tap on a grid mission (or any other mission plan offered) after a few seconds, and there is no loaded map. I tried to zoom in and out, but only grid network apears.
I use Phantom 4 Pro+ (ctrl+dji and pix4d capture apps).
What could be a problem?

I had similar trouble. I have 2x Mavic Pro 2 and 2x Ph 4 Pro 2. I use Pix4D capture and DJI Ctrl+DJI on my crystalsky HB 5.5". From other [threads] (Using Google map as background map - #27 by Gael), MapBox is unsupported and dead but people found these links work to add Google Maps:
In Plan New Mission screen > settings > under Maps > Street basemap provider > + icon >{x}&y={y}&z={z}&s=Ga > OK

Satellite basemap provider > + icon >{x}&y={y}&z={z}&s=Ga
I had no trouble with one Mavic, the other I fussed over for ages, uninstalling, reinstalling, logging in and out, repeating - THEN I tried zooming out, took many zooms out then went from blue or black (depending on in in street or sat view) then eventially found imagery. All good now