Support Website Contact Support Blog

UAV Imagery collection presents unstable spacing

Hi pix4d,

we are using Pix4Dcapture to set P4/DJI mission as follows:

Device/Mission: Samsung Tablet (Android - Lolly Pop), 13 minutes flights @300 Ft (covering ± 40ha) -->  2 seconds per shot.

Target: process images in flight to get consitant mosaicing preview. (Images are land processed by Pix4d/Pro to benchmark our system results.)

**Problem: after a certain amout of images (~70) shots the spacing of images becames unstable (shots are taken randomly at 2, 4 or even 6 seconds) messing the planned overlap and so hurting on board processing.

Have you had some similar experinece?

See attached the Pix4D reports from our last 3 flights:

 

         

     

Hi Embrapa,

To clarify the situation, there are three different picture triggering modes for the simple grid mission.

  • Android: The action to shoot a picture is based on a time lapse. The app requires to be connected to the drone time to time to get a feedback about its position.
  • iOS Safe: The drone stops to take every picture which significantly increases the flight time. The way-points where to shoot are uploaded to the drone before starting the mission. This means the drone can fly the mission without requiring a connection with the app.
  • iOS Fast: The app sends a signal when to shoot. This mode does not make the drone stop but the connection with the drone should be maintained without interruption.

We have continuously improve the picture triggering mode on Android. It is true that this was less stable in the past. We expect that the latest Pix4Dcapture 3.5.0 will give you better results. However, the non-regular interval between the images should not be a problem for processing on Pix4D desktop.

Regards,

This is the exact same issue I have with the same drone but using iOS.  Your grids look exactly like mine, the first couple of lines of the grid have the correcti mage spacing but every one after it becomes sporatic, this is my constant issue as well with Pix4Dcapture.

Hi,

Thank you for your feedback!

Our developers are continuously improving the stability of the picture triggering. Are you using the Fast mode of iOS or the Safe mode?
Did you perhaps have the chance to test the latest iOS app released on February 16th?

Regards,

I flew with then newest version of the Capture app yesterday and it was causing a new issue with my Phantom 4. I created a grid and the Phantom would fly the first line but started rotated and would continue to rotate as it moved along the grid capturing images. I aborted the mission and tried 3 times but it would start at the exact same rotation and rotate the same way each time. I have tried the Capture app with my updated iOS device in both Safe and Fast modes and I continue to experience the same issue of images not triggering. I thought Safe mode would ensure an image trigger but the Phantom would stop at each location as if it were taking a picture but the image capture was not initiated.

Could you please send us the app log file of this mission via a Support request form so that we further investigate?
For more info about the log file: https://support.pix4d.com/hc/en-us/articles/215281483

Regards,

I have sent the requested logs files using the Support request form.  I hope you are able to identify an issue that can resolve my problems.  I have been having issues with the capture app since I started using it last year.  Initially it would not initiate the image captures and now it has the Phantom rotating as well.