Trouble in Calibration of Pix4DCatch data due to bad RTK Solution

Hello. I am michael. Currently, I am working on a large project to scan a large sidewalk area using Pix4DCatch on iPhone 14 pro attached with viDoc RTK. My study area is in Tainan, Taiwan.

Additional information:
Before 16th Mar 2024, I can’t have an ‘RTK fixed’ solution on my viDoc RTK and Pix4DCatch. Starting on 16th Mar 2024, I was able to connect to the NTRIP base station and receive an ‘RTK fixed’ solution.

The problem that I got:
On my study site, a part of my study area is relatively open which has less tree coverage, and other part is heavily covered by tree or under the building. Currently, I only succeeded to calibrate image data of the area with relatively low tree coverage.

How do I process the project if the image position is incorrect due to bad signal or ‘DGNSS only’ RTK solution during image scanning?

Example of the project: The image below is the imported image. The calibrated image that I am hoping to get is that the image drawn over with yellow line should be corrected following the red line. note: I drew an arrow to guide you the correct image position)

Solution I have tried:

  • The local company suggested not to do a loop scan (where we are going around and going back to the starting point at the end of the scanning), but I decided to do it to compensate for the transformation issue.
  • Currently, the only solution I know is to retake the scanning again, but it is very hard or even impossible to get an ‘RTK fixed’ solution under the building coverage.
  • I have tried to add some manual tie point (MTP) to assist the calibration, but the calibration only shows that the tie point I have selected as ‘outliers’ instead of compute it.

I am sorry, I can’t provide more images. I only allowed to submit one image. If you have any suggestions regarding data processing or scanning procedures to fix this problem, please inform me.

Thank you.

Best regards,

Hi @Michael_vashni

Thanks for explaining the issue and adding an illustration. Losing the RTK signal is typical if you’re below a heavy tree coverage or near tall buildings.

Something we’ve developed to help in such situations is to lay down some “Auto Tags” in the tricky area, which will be automatically detected by PIX4Dcatch when passing by. Those tags can be surveyed and be used as GCPs, OR be used as MTPs (that you won’t have to click).

Here is the article about using them as GCPs:

The article is not up to date yet with the MTPs workflow, but the idea is that you can use the same targets that can be downloaded and printed from the link above. Then you need to go in Settings > Advanced Settings > Enable “Geofusion Auto Tags” in PIX4Dcatch. This will autodetect those targets and create a marks file in your export folder, that you can import as “marks” in the tie points table in PIX4Dmatic, click “…” > Import marks.

For the data that is already acquired, and the MTPs you clicked, you likely need to mark more images. All images that see the points if possible, in some cases it’s not enough to remove the “outlier” status, but this can change if you reoptimize or reoptimize with rematch. The latter is what makes the MTPs be taken into account by the project. Then you can try adding more MTPs to fix the situation. and reoptimize again. (it’s an iterative process).

1 Like

Thank you for your response.

The idea of Auto Tag is interesting. However, I don’t find this applies to my case due to the size of the study area can be considered as a quite large area. But it is a good thing to know this feature.

I will try working on the adding more MTP.

Thanks for your suggestion. I really appreciate it.

1 Like

Hi @Michael_vashni,

I’m happy to hear that you appreciate Pierangelo’s suggestion.

Considering your use case, with a project extending over two blocks, you can still get satisfactory results using automatic tag detection if placed in strategic points.

We are currently refactoring our documentation for PIX4Dcatch RTK. An updated article will be released in the next few weeks. Thank you for understanding.