Support Website Contact Support Blog

Trouble flying second mission

Hi all,

Using Mavic 2 Pro and latest version of P4D Capture. We uploaded one mission grid of an area and wanted to fly a second mission of the same area with a double pass grid. After we flew the first mission, the we landed the drone, switched out the battery pack, and tried to take off. There was a warning saying unable to upload mission plan (for the second mission) so we turned off the drone, restarted the app, and the second attempt the drone was able to sync mission plan. We started the flight plan for the second mission, but the drone flew to the starting point of the first project, not the second project. We tried turning everything off, resaved the mission, and restarted the apps/connection of controller, but we could not get the drone to fly the second mission, it kept flying the first project again. Any ideas what is going on and how to fix that in the future?

Thanks!

Hi,

Are you using the iOS or Android version of Pix4Dcapture?
Also, we you operating multi-battery flights? If so, there is a specific workflow to follow that is explained here.

Was the first project completely finished before you tried to fly the double-grid?

So far the behavior you are describing has not been reported, I would suggest you to go all along the basic checks and troubleshooting steps. If properly followed, it will enable you to solve most of the issues that can be encountered by users.

Best

Hi Gael,

We were using the iOS version of Pix4Dcapture. It was a single-battery flight, one battery for each attempted project. We did finish the first project before starting the second, landing the drone, changing the battery and starting the second project. We had the second project loaded on the P4Dcapture app and pushed start on the second project when the deviation occurred. We went through the procedures of basic checks and troubleshooting which did not change the outcome, which is why I came to the troubleshooting forum to see if anyone else had experienced this.