Support Website Contact Support Blog

Difficulty with multi-battery double-grid flight

In my last mission I had some very frustrating issues. I was performing a double-grid flight that required multiple batteries. As expected, once the drone had completed the first 99 waypoints, it attempted to return home to land. I paused and resumed the mission and it continued and completed the next 99 way points. At this point, the battery was a bit low, so I let it come home and land. The drone correctly continued the mission with the second battery, completing 99 waypoints with no problem, and then attempted to return home.

Here’s were the trouble started. I attempted to pause and resume the mission again. However, when it resumed, it returned to an earlier point in the mission and started to repeat 99 way points - obviously a big time suck and very frustrating. Strangely, though, the app was recording photos (by placing camera icons) on the correct, previously unflown part of the mission path. However, the drone itself AND the drone icon in the app, were most definitely flying on part of the mission path that had already been completed.

I attempted to pause and resume the mission several times and eventually landed and replaced the battery, turned off all equipment, restarted pix4dcapture and reloaded the mission. However, I could not get the drone to map the portion that had not yet been mapped. Rather, it would either resume the mission by proceeding to the portion of the mission that had already been flown, or by flying to the launch point, hovering, then returning to the part of the mission that had already been flown. I also tried just letting it refly those 99 waypoints, but when it reached the 99 point limit again, it tried to return home and I started this whole problem over again.

I was able to make a kind of work-around by duplicating the mission and adjusting it to cover only the portion that hadn’t been done yet. This let me get most of the project done, but eventually i was in the same situation again, with a small portion of my mapping area incomplete and the drone refusing to fly that part of the route. Again I duplicated and adjusted the mission, but this time - even though it was a new mission! - the drone continued flying the previously-flown part of the old mission. I have added a screenshot of this for reference, where you can see the drone icon (representing the actual location of the real drone) and the green line (representing the path it has flown so far - which is part of the old mission) and the camera icons (erroneously placed where I wish the drone was flying). At this point I gave up in frustration.

In all cases, the app indicated that the mission had been properly uploaded to the drone - no errors or warnings whatsoever. I’m flying a Mavic Pro with the latest firmware updates using an iPad Pro IOS version 11.2.6.

Is this a known issue? A glitch? It makes larger missions incredibly inefficient if not impossible.

Hi,

Thank you for the detailed description of your issue.
With a specific configuration combining iOS/Double grid/Safe mode and by bypassing more than twice the 99 waypoints limitation, the issue you are describing has been reported by some users and we have been able to reproduce it. This behavior has been then reported to the developer’s team.

In the meantime, to avoid this behavior, I would suggest tapping PAUSE/RESUME no more than once to upload the next set of waypoints so that you do not encounter the bug. Also, you can fly using the Fast mode as it will enable to acquire a good image dataset in most of the cases.

Best,