Support Website Contact Support Blog

[iOS] Drone keeps returning home mid-mission

We’re running a DJI M200 with X4S for mapping missions using pix4d capture.  The drone will fly the planned grid for about 10 minutes or so, and then return home for no reason.  We are running a 128GB card in the unit as well.  We have tried 2d map flights, polygon flights and 3d map flights, and they all do the same thing.  We are current on all software and firmware as well.  We have also tried with a DJI Inspire 2 with X4S, and the same thing is happening.  Please help, it drains the batteries traveling back and forth so much, and also makes the project take longer than it should.  Thanks.

I had the same problem with my Phantom 4 Pro, and apparently if you are using a IOS device, and using safe mode, so the drone stops every time it has to take a picture. This means that everytime the drone is supposed to stop, capture sees that as a waypoint, and for now it’s only capable of having 99 waypoints. So this means it automatically returns home after the last waypoint. 

Try using fast mode and slower speed, it should solve problem. 

 

Hi Eric,

Joel is right, I assume here that you are using an iOS device with the Safe mode to trigger pictures?

Pix4Dcapture uses two different methods to trigger the camera depending on the flight mode you use. You can learn more about the differences between the two flight modes, Fast Mode and Safe Mode at (iOS) Pix4Dcapture - Manual.

DJI’s SDK does not allow third-party applications, including Pix4Dcapture, to upload more than 99 waypoints at the same time. Unfortunately, this means that we expect your drone to pause mid-mission when it reaches the 99th waypoint. Please note that when flying in Safe Mode that every image requires a waypoint so your drone will fly fewer than 99 flight lines before pausing.

To check if you exceeded the 99 waypoints limitation, you can open the project associated with your flight. On the right side of the screen, you will see the number of images acquired and the status of the mission (if it has been completely flown or not). If 99 images have been acquired and the mission is not totally finished, the 99 waypoints restriction is most likely responsible for your drone stopping during missions.

In the meantime, possible workarounds you can consider include :

  • Planning a smaller mission and/or decreasing the amount of image overlap so that the mission does not include more than 99 waypoints limitation.
  • Tapping Pause and then _Resume _in Pix4Dcapture when your drone stops during the mission so that Pix4Dcapture can upload the next set of waypoints.
  • Switching from Safe Mode to Fast Mode. Fast Mode does not rely on waypoints to trigger the camera so you can fly more flight lines before exceeding the 99 waypoint limit.

Hope it helps,
Best,

I now have this same issues with my Mavic 2 pro. It’s odd because the week before today it worked no problem. Issue mission pauses and returns to home and when I resume it just repeats returning to home. Please help as I only have 7 more days remaining for my trial.

Hi Charles,

Are you dealing with the specific issue mentioned above using the iOS version of Pix4Dcapture and safe mode to trigger images? What is happening exactly, can you describe a bit more the issue?
If bumping into the 99 waypoints limitation, did you try the workarounds described in the previous comment?

Also, make sure that no settings in DJI GO 4 can lead to the behavior you have. For example the value defined for the low battery RTH.

Best,

Hello Gael,

 

Thank you for your quick response. I’m running iOS version 12.1.4 (16D57) please clarify when you ask about “safe mode”. My Mavic 2 is always in “ P” mode and my iPad 11 is not in safe mode perhaps you have more details about “safe mode”?

More details: 

After about 4 min into a 7 min scan job the drone returns to home then ask to resume. I hit resume and the drone resumes scanning but never completes the scan just repeats for another 4 min and returns to home and prompts me to resume again. This process repeats over and over yet the drone neve4 completes the scan.  Dji software version 4.3.12 (4292) running latest firmware. Battery set for 20% crital low battery set for 15% . Please provide detailed instructions on what you reference above about waypoint limitations. Just FYI I’m only scanning about half a football field. Can you please explain with more details on resetting or eliminating any waypoint restrictions/limitations.

I also noticed that on the grid I do not see the drone laying those camera icons like it used to do letting me know it’s taking pictures every so many secs.

 

Cheers

 

 

 

Hi Charles,

Sorry for the delay. The Safe mode an acquisition mode to trigger images while flying a mission.
It can be selected In the mission Settings --> Advanced.

If using the Safe mode, the drone will land after the acquisition of the 99th image whatever battery value you have at this stage of the flight. Is it what you are experiencing? If yes, as explained in my comment of the 27/07/18 on this thread, it is linked to a DJI restriction when it comes to upload waypoints to the drone for an automated mission.

Best,