Support Website Contact Support Blog

Pix4D Capture App Crashing Mid Flight (IOS - Ipad 4 Mini)

I’ve been trying to use Pix4D Capture and our Mavic Pro on a couple small sites. 

Settings are as follows.

Double Grid, Camera angle 65 Degrees, with 75% overlap front and sides, Fast Mode.

I’m actually getting a couple of weird issues. 

Issue 1: The first grid is flown and the first row of the crossing grid is started.  Instead of capturing images in Fast Mode, the first row, switches to Safe Mode.  Once the First row of that second grid is flown, the mavic switches back to capturing pics in Fast Mode. 

 

Issue 2: This is the bigger of the 2 problems. 

On the same mission as referenced above, Double Grid 3D Mapping/Model mission, before the second grid is complete (Roughly 60% complete), Pix4DCapture crashes.  The mavic continues to finish flying the remaining grid patterns, but does not collect any more images. 

Initially, I thought the flight finished as it should, but once back at the office I see that All the images did not get collected. 

So, why is my App crashing?  I Force quit all apps, then force a shutdown and restart of the Ipad before beginning to fly with Pix4D.  As stated in the title, I use an Ipad Mini 4 with the latest Pix4D Capture software. 

This has happened on 5 different missions over the past 2 days, all of which were extremely close in size, with roughly 15min flights.  803’x442’ Double Grid to be exact in sizing @200’ AGL

 

Any help appreciated,

Cliff

Hi Cliff,

Issue 1.: Also some other users noticed switching between Fast and Safe mode when flying double grid mission on iOS. Our developers are currently working on it and it should be fixed in the following days. Make sure to install the latest version once it is available. 

Issue 2.: 

At the moment there is no obvious reason why the app is crashing on your device. Did you maybe have the chance to test it on a different device?

Give it a try with the new version that is coming out in few days and let us know if the issue remains.

It is expected that images are not taken after the app crashes. At that point the communication between the drone and controller is lost and this results in missing images. We recommend to press the RTH button on the controller after the app crashes. 

Best,

Thank you for the quick response. 

As far as Issue #1, I could really see this being a big issue if I was flying at close to the limits of the battery, and switching to Safe mode causes the battery to die before the flight is actually complete.  

 

Issue 2: No, I have not had a chance to test with a different device.  At this time, I’m not even sure if I have another device to try it with.  I will see what I can find to test with.  Is there a way to share the flight plan, so that I can be sure all settings are the same for testing purposes. 

I guess I was just a bit shocked, when the entire flight plan/Grid seemed to be uploaded in the beginning and after the App crash, the the Mavic continued to fly the grid, but the images were not collected.  Why would the image collection data not be uploaded during the same time the flight plan is uploaded, that way if an App crash occurs, the images are still collected?  

Given the responses above to both issues, it might be a good idea to add a feature to Resume a previously incomplete flight plan.  This might help and make it easier to collect the remaining data after an app crash or if a single battery cannot complete the mission for some reason.  

Cliff 

Hi Cliff,

I had the same problem, Pix4D crashed in the middle of the mission. Maybe, because the Ipad was too hot and became instable. 
What I do is to put an icepack on a towel and then I put the Ipad on the towel.

Sebastien

I don’t believe it’s a heat issue, as I use my iPad Mini in the sun and heat a lot. I’ve learned how to normally keep it cool enough to continue to function properly, and mostly, this is as simple as keeping the glass screen out of direct sunlight and angled away from the sun. Additionally, on this particular flight, it just wasn’t that hot outside, which has a direct effect on the temp of the iPad.

It is just odd to me that it crashes at virtually the same spot in the flight each time.  Three times with basically the same flight plan in 2 different locations, it has crashed at basically the same spot. 

 

Cliff

I have the same issue: at a certain time the camera stopped triggering and in another mission no photo has been taken, but mission has regularli ended without photos.

 

@BLANK, nice way to cool down the device (;

@Cliff, did you maybe have the chance to test the app with the latest version? Let us know if the issue persists.

To clarify:

  •  iOS Safe: The drone stops to take every picture which significantly increases the flight time. The way-points where to shoot are uploaded to the drone before starting the mission. This means the drone can fly the mission without requiring a connection with the app.
  • iOS Fast: The app sends a signal when to shoot. This mode does not make the drone stop but the connection with the drone should be maintained without interruption. It is solely based on the position of the aircraft.

As you were using the Fast mode the way-points were not uploaded for every single image but just for the flight plan.

Indeed, the resume option would be beneficial in the case you are mentioning. There are already users with similar feature request. Have a look at this thread: (iOS) Multi-battery flight / resume option.

@Antonio, have a look at the following thread for more information: (Android, iOS) Images are not captured.

Best,

 

Unfortunately, I have not had a chance to get back to the same site and test again.  I hope to have time this week to tr with the new Pix4D Capture version. 

Yes, I was in Fast mode as it “Should” have provided quality good enough for my purposes, considering I was utilizing ground control points. 

Why would ALL the waypoints for image collection not be uploaded prior to flight start in Fast mode, so that it acts like Safe mode and does not require a connection all the time.  Seems to me this would eliminate the problem I’m having. 

This question might be best suited to a new topic, but I’ll start off asking here. 

Why do we need “iOS SAFE”,  Pix4D works perfectly fine utilizing a Fixed wing that cannot stop and hover to collect a pic, so why would it be necessary to stop and take a pic, just because I’m flying a multicopter? 

 

Thanks,

Cliff

There is another big problem using “safe mode”: the flight time increases and so it needs to divide project in other subprojects and merge them all together, wasting important time.

1 Like

I found time to go out and fly the same mission as shown above in the pic.  This time, everything worked as expected, it did not crash, and images were picked up for the entire double grid. 

That makes me happy. 

However, Maybe I just can’t find the place to set it, but it would be nice to give a name or description to the saved missions.  Mine are auto named to Pix0001, Pix0002, Pix0003, etc.  Or something cryptic like that as I don’t have my iPad in front of me currently. 

Cliff

@cliff, I am glad to hear that the latest version resolved the issue you were facing (;

At the moment the name of saved missions on iOS are automatically generated and it is not possible to rename it or add a description, e.g. Project 00001. I will forward your suggestion to the project manager in order to take it into consideration.

And to answer your second question about Safe/Fast mode. The Fast mode is the most used option since it allows faster acquisition. It does not use coordinates/positions of every single place where images should be taken but relies on the signal that is sent from the device. 

On the other hand, when using the Safe mode all positions of images are uploaded to the drone. This makes the upload and  acquisition much longer (drone stops for every image). For example, Safe mode is used for thermal cameras that are very sensitive to movements and need to be taken on a steady platform. 

Best,

@cliff

May I ask what version of iOS on your iPad mini 4 and what version of Pix4D Capture on you iPhone (I suppose) did you use?

Hi.

Issue 2: I also experienced the app crash, and as a cause of that, I had to fly the same mission three times. 

Please fix this bug. I only have so many batteries…: issue:

Issue 3: For some reason when I start the mission preflight in the pix4D capture (the screen where it checks everything is in order before takeoff), The “Getting the camera ready” option does not change from gray to green. 

I use an Ipad mini4, the latest pix4D capture version, and a DJI Phantom 4 Pro. (latest version)

I wasn’t able to find a stable troubleshooting solution, but after restarting the app and the drone/controller, it eventually worked. Please explain.

 

Thank you!

We are aware of some crashes in iOS but were not able to reproduce them so far. Our developers are working on it.

The camera can take some time to be ready. To solve this, we recommend to restart the mission over to refresh the status of the takeoff checklist and force the reset of the camera.

At least I am happy that you managed to fix it, but I will follow up via the support ticket that you created.

How can I force the reset of the camera?

Hi Guys,

Has anyone found a fix for the i pad Mini and the DJI drone problem?

My I pad mini model (A14890) No longer Connects to my DJI Inspire 1 using Pix 4d app. Before it didn’t connect, it used to crash mid mission and take a long time to send the mission to the drone and take a long time to set up the camera. Now nothing happens at all.

I am running all the latest firmware updates and so on.

I just wondered if anybody else is having this issue? as at the moment I am unable to carry out any site surveys.

 

 

 

 

 

So annoying sometime I lift the drone and move it in a figure 8 pattern to get the camera to engage and bam green check mark.

 

@Antonio
Restarting the mission over will automatically force the reset of the camera.

@Daniel
I would suggest to proceeded with checks and recommendations detailed in this article.

@Ryan
I am not certain to understand the issue. Could you please provide more information and ideally a screenshot if it applicable?