Support Website Contact Support Blog

Texture quality and geometry worse in 3DS max than pix4d viewer

Hi

I’m trying out the Pix4d, as I want to create a 3D mesh with textures to use in a VR model. I used a sample project, and exported it as obj to 3DS max. When i open it it in 3DS max it is the edges get rounded and details get blurred. What can I do to get a high quality 3D Mesh in 3DS max?

 

The map resolution in your 3DS Max display is affected by your viewport display texture resolution setting (which is limited by your graphics card memory). You may need to reload the map (by editing the material) or the scene to see it update in the viewport.

I’m not sure why your mesh looks worse… It could be that Pix4D and Max are smoothing the model differently.  Try applying a smoothing modifier and play with the smoothing options to make thing look less lumpy.

-Donald 

2 Likes

Thank you. The resolution looks much better now.

Is there any import settings I can change to get the mesh looking better? I don’t want to add a smoothing modifier as it would ruin the geometry of the buildings.

I think you want to use the Smoothing modifier to remove or adjust (auto) the smoothing. 

To get rid of the potholes, you could edit a copy of the mesh and use Reproject to bake the texture map back into it. 

Hi Asrer,

I am glad to see that Donalds’ advise helped improve your mesh,

There are indeed some import settings to follow to correct the 3D Textured Mesh in 3DS Max, these settings are detailed in the following article:

https://support.pix4d.com/hc/en-us/articles/211029783

In the past these options worked, please give it a try and give us a feedback on how it worked.

Best,

I’v found the best method to reduce the bumpines was to use the relax modifier for only the ground https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/3DSMax/files/GUID-4D0327CC-BDC3-4687-8158-042436CE4FCD-htm.html

I didn’t do anything with the houses or the cars, as they look like they were melted when using this modifier, instead I just cut them out from the mesh as an own object using detach under polygon.