Support Website Contact Support Blog

Importing in 3dsmax for use in Unreal Engine VR

Hi everyone! 

We just recently finished processing several flights and output a few very nice, crisp 3d models. We want to import the models into 3DSmax for clean-up, with the eventual goal of adding them into a VR environment built in Unreal Engine. 

However we are running into a major problem: When we bring the models (.fbx/.obj) into 3dsmax the quality is atrocious. It goes from being photorealistic to looking like it was made by a gradeschooler using playdough. 

Does anyone else have any experience bringing pix4d output models into 3dsmax? And even into Unreal? Any insight on your workflow would be appreciated. 

Thank you! 

Anybody have any ideas as to why I’m h having this issue? 

 

Here’s two images for reference. First is Pix4d. Second is 3dsmax.

 

Can you share the processing options you have used for the 3D Textured Mesh? Maybe 3DS Max does not handle high resolution settings and tries to downsample the mesh. 

I found this similar post about this issue, but there is no solution so far. Hope that someone more experienced with 3DS max can help out here. 

EDIT: Maybe try changing the illumination of your model in 3DS Max as described here: https://support.pix4d.com/hc/en-us/articles/211029783

Hi Pierangelo, 

My processing options are as follows: 

  1. High Resolution

  2. FBX, OBJ export. 

and that’s pretty much it. If it matters, I am using 1/2 image scale, optimal point density, and 3 min matches for my point cloud settings. 

What’s odd is that we imported the photogrammetry directly into Unreal Engine 4, and it look MUCH better. We still had to retopologize some of the rough spots. 

What I seem to have found is 3dsmax and Unreal import the photogrammetry correctly, but the textures and colors come out strange. For example, certain pillars have clear “craters” before we retopologized. However you don’t notice the craters since the colors blend in Pix4d. However the same is not the case in 3dsmax and Unreal. I think it my be the appearance of shadows/lighting in 3dsmax and Unreal that cause craters and other imperfections to be significantly more apparent. 

In short, I think you’re right in regards to illumination. I will do some more testing when I get back to my pc. 

1 Like

Hi Alek, 

Thanks for sharing further insights. I recently saw an issue with the “Qualitative> Straegy: sensitive” setting in the high resolution mesh options. There was a case where the mesh would get somewhat blurry. Something you can try is to set Custom settings and select “Quantitative” instead. Maybe this could improve your output as well, see the screenshot below:


Let us know if you test the illumination settings in 3DS or the tip above.