Support Website Contact Support Blog

SERIOUS Mouse Misalignment/Calibration "Ray-cloud Anomalies"

Hoping someone can help (Pix4D Staff inclusive). I’ve seen this post prior, and I searched the solution profiles and could not find.

I’m having a SERIOUS mouse calibration issue. It’s depicted below. The “Arrow” I drew in the lower left corner of the image below is the ACTUAL position of my mouse (that’s where I’m ACTUALLY resting/pointing). The software is picking up the target point and RELATIVE position  precisely where it is highlighted in the middle of the screen between the “Green” crosshatch (we’ve “adapted” but its a headache). Likewise, we are loosing all “Alpha Transparency” on bounding boxes (ie, “Point Cloud Clipping Box, Processing Area Bounding Box”- doesn’t matter what the settings are, their Opaque, always)./

This IS to be clear, 100% Hardware. We’ve seen it before ourselves.

I’m simply hoping someone from the Community and/or Pix4D can reply with a few suggestions (private is fine too), with a recommendation for a new Monitor that works (it would help if you keep your “shopping eyes” under $500 USD for us…LOL). I’m not sure if it’s the Mouse either (we are using a Logitech MX Master…perhaps their drivers are causing it…we tried "Unistall, and then a generic USB Mouse…no luck).

The Monitor (culprit we are assuming) is an ACER Ti27 IPS 10 Point Intelli-touch (we don’t have this problem with the Surface Touch, ported this project to our field Laptop which is a Surface Laptop- the new monster).

We DID have the issue prior to the GPU Card change as well, it didn’t help (we’re ruling out the 1050ti).

Assuming it must be the Monitor…or Mouse…or something we haven’t configured…???

Bad non compliant hardware, “needs to go”…we’re on board with that. Please help with a suggestion on new hardware and/or “Models that seem to be ok”

Appreciate the help from anyone!!!

Happy Holidays to all!!

Chris

System:

Windows 10 Pro (64 bit)
NVIDIA 1050Ti
i7 6th Gen
128gb RAM

ACER 27"TI Touch (HDMI in right of the NVIDIA Ti1050- all Driver are updated)

 

Hey Chris, 

This seems to be a display issue. Can you try this out and let me know if it works: 
Right-click on the pix4dmapper.exe file,
select the Compatibility tab and
enable ‘Disable display scaling on high DPI settings’: the checkbox below should be checked.

 

Hope this helps,  

3 Likes

Hey Marili!!

That worked perfectly.
:grin:
Thanks a million (and saving us a monitor purchase as well…!!!..)

Totally appreciated.

Cheers.

-Chris

1 Like

Great!

I am very happy to hear that :-). 

1 Like

I am having this same problem and tried the above and it is not working.

Hello Tylor,

The DPI setting is now called “Override high DPI scaling behavior. Scaling performed by: Application.”

After clicking on Change high DPI settings:

 

The option can be checked:

 

Please let me know if that heps.

 

 

 

1 Like

I am having this same issue, I am running 3 monitors. One of those is a TV that is not my main display. The mouse pointer only works on the TV monitor. Both of my two Dell monitors have the pointer issue. 

This occurs both with and without the override checked as shown above.

Hi Zach,

It is difficult to know but it seems a scale problem. Please try with the setting to fix the scaling problems too.

Thank you very much.

Daniel, I ended up doing some troubleshooting and found a workaround. The TV monitor on my setup is ran on hdmi over cat5 and that is the only display that pix4d would not have an issue on. I disconnected that TV display and my dual dell monitors worked flawlessly. Somehow the program is picking up settings from that display even though it is not set as my main display.

Thank you for the feedback.