Support Website Contact Support Blog

Serious graphic artefacts after init. processing and geo-optimisation

Hi,

I’ve been testing Pix4D Discovery (without activating the Pro trial) and after several successfully processed image sets I started having a very weird and permanent problem - After I load my images, I import my GCPs, use the basic editor to mark three-four of the GCPs, just to have a good orientation and then I do the initial processing. I get a sparse point cloud, aligned by my three GCP’s and then I use the Raycloud GCP editor to mark the rest of my GCPs. Then I click Re-optimize and the result is a very well aligned point cloud, but the display is very distorted - I don’t see the cloud in its full, there are artifacts while I rotate the view and it generally looks awful. I have attached two screenshots of the problem - it is the same project. You can see how it looks like there are black rows between the points.

 

Do you have any idea why this happens?

I’m having this same problem as well. I’ve been trying to figure out a good workflow that will elimate this. I’ll keep you posted. I’ve been having to revert back to older versions of Pix4d to elimate it.

 

So I reran a project that Pix4D was doing this to. I don’t know why it fixed this error but it does. So basically all I did was Change the out put coordinate system from Arbitrary, back to known coordinate, then back to Arbitrary and reoptimze and it fixed it…

1 Like

Hi, Erik!

Thank you very much for the input! Your method works - I tried it on two of my projects with this kind of problem. I also cannot explain to myself why it is working, but it is!

Yesterday I thought it was my graphics card driver, I have an Nvidia GTX 960, which is a good card for Pix4D, I downloaded the latest drivers, I updated Pix4D to the latest version, but I always got this strange problem…

I really think someone should diagnose this problem and fix it, I don’t know how often it happens to other people…

Once again many thanks and cheers!

No problem. Its been haunting me since the 2.0 update and just finally figured it out…

Hi enveryone !

 

I have exactly the same problem with a quadro K220 graphic card. At the beginning, i wa thinking about a bat generation of point cloud density but in fac it’s just a display problem. It’s impossible to drw volumes with this. Please PIX4D, try to solve this quickly !!

Thank you.

Hi all,

Do you still have the this problem?

@Arnaud: Do you work with an Arbitrary coordinate system as well?

We believe that this is not a display issue. It is related to the use of an Arbitrary coordinate system. We have tried to reproduce the issue but we cannot. 

Please give us more information about your project and the steps you did in Pix4Dmapper:

  • Does your project have images coordinates?
  • Are your GCPs in an arbitrary coordinate system?
  1. You create a project with no images coordinates
  2. While creating the project, you should select the output coordinate system : You set it as Arbitrary
  3. You marc 3 GCPs using the Basic Editor (make sure that the GCPs’ coordinate system is the same as the output’s coordinate system: Arbitrary)
  4. Reoptimize
  5. Use the rayCloud to mark the rest of the GCPs
  6. Reoptimize

 

Is this what you did?

The above mentioned workflow should work.

We would be glad to hear your feedback on this topic.

Best regards,

 

 

Hi Christina,

Just FYI, I just ran into the same issue. I am following the steps in this post to a T:

https://support.pix4d.com/hc/en-us/articles/204515169-How-to-compute-the-Site-Calibration-for-GCPs-in-an-Arbitrary-Coordinate-System#gsc.tab=0

I had processed a project in a known coordinate system, then I changed the output coordinate system to arbitrary, and it now has a bunch of ‘lines’ of points…see below. Do you have a solution for this?

 

 

Hi Jon, 

Have you tried Tim’s suggestion in a previous comment?
https://community.pix4d.com/t/4736/comments/205726526

Does the issue appear after a specific step described in the instructions from the article you linked to?

We are having the same problem with this but we are having the issue when we combine a project with a known coordinate system, with an arbitrary coordinate system. It has happened on the last two project we completed in this way. A side product of the process made it so that the initial camera positions were projected about 2 miles away from the computed positions which was also not right.

However, we actually tried the suggested fix on this latest project and it worked just fine. We switched from known coordinates to arbitrary, then back the original coordinate system and now our positions are fixed and the visual glitch isn’t happening.

One thing I realized is that I have had this issue before in other programs. It actually is a redraw problem when something is too far away from the 0,0,0 origin. I was having this same problem in a point cloud view program and upon discovering that it was nearly 10 miles from the origin I moved it, and moving it fixed the glitch.

We have another few projects that we will do in this way again, and if it continues to happen I may put a support ticket in. And I don’t know if it would help to send over our processing files. Anything we can do to help with this we’re available.

1 Like

Andrew, 

Thanks for your detailed explanations!

Do you have Manual Tie Points (MTPs) and/or Ground Control Points (GCPs) in the overlapping area between the two projects you combine, as described in the Merging Projects article? 

If you could share a project (images, .p4d files, result folders of both subprojects) where this behavior can be reproduced consistently, I will try to reproduce it on my computer. You can either share a link on this post, or submit a support ticket if the data should not be public. Please also add detailed steps that lead to the problem, this will vastly simplify the investigation. Thanks for your help!

Yes, we do manual tie points between subprojects and we follow the merging projects article guidelines. We do not use GCPs as the level of detail required isn’t that high for the projects we are working on currently.

I can share files, I will check to see if they are reproducing the same problem consistently first then will create a support ticket.

1 Like

Thanks Andrew for your explanations and for sharing the files. 

In this case, what seems to happen is that when merging a project with a known coordinate system with a project in an arbitrary coordinate system. The merged project has the known coordinate system as output coordinate system (NAD_1983_StatePlane_Oklahoma_North_FIPS_3501_Feet). However, the values of the coordinates are the ones from the arbitrary project. This creates a huge shift between initial and optimized camera positions and leads to graphic glitches. I reported this as a bug to our developers, so that it is documented. The product manager informed me that they will not work on this bug for the moment, so I would recommend anyone who has this issue to follow the workaround described above by Tim and Andrew: 

"We switched from known coordinates to arbitrary, then back the original coordinate system and now our positions are fixed and the visual glitch isn’t happening."