Support Website Contact Support Blog

Problems with image geolocation

I have 625 images from a P4 Multispectral (5 bands x 125) which I am trying to load into a project. Pix4D seems to be reading the location info from EXIF data as it says 625 out of 625 images geolocated and the table is populated as expected (including horizontal and vertical accuracy), but rather than a green tick I have an exclamation mark.
Possibly as a result, when i try to select the Ag Multispectral template, I get error e9029b unable to select template, not enough geolocated images.
Also, once I start processing, in Map View the images aren’t showing up, I just have the default ‘world view’ map.

Any suggestions what might be going wrong?

Hi @damian.bienkowski,

Can you please send us a screenshot of the issue occuring?

Also, you can also process images in Pix4D that are not geotagged. After importing the images choose 3D maps template, that will not give you any error (as 3D maps template uses standard calibration method that does not use GPS data). When You come to the main Pix4D window, go to processing options>Template and select ag multispectral. Change the calibration method to standard. Click Ok, start processing.

Let me know if you have any questions.

Best,

Thanks Nikoleta. Here’s a screenshot

And thanks for the suggestion about changing templates - will try that.

Hi,

Can you try it and let me know how it goes?

Best,

Initial processing has finished and now it has hung while displaying the quality report unfortunately so I’ll have to close. Looking at the parts of the log that I can see I’m getting multiple errors along the lines of 'warning w9020: GDAL Error… 1_initial/report/html/dsm_preview.tif: No such file or directory.

It’s a clean install of Pix4D. I’m running Win 10 64 bit on an i7-8650u with 16GB RAM so should be just about meeting the required specs.

If I switch to Standard calibration, then try and change template, it reverts back to Alternative calibration, which gives the warning about not enough geolocated images, and an error ‘Invalid value in calibration tab’. Switching back to Standard, removes the template.

OK, have now tried it with 3 separate datasets. All process fine on my main machine, all getting the same issues as in my 2nd post above on laptop: data seems to be read in OK, the table is populated, but there is still an exclamation mark beside the Geolocation info, and I can’t then run Ag Multispectral because ‘not enough geolocated images’.

Hi Damian,

It is ok if the template is removed.
This happens because you changed a processing option from the original template. The rest of the options remain the same.

Regarding the warning, you are receiving it is just a warning, not an error, but if you do not need the preview of the orthomosaic you can disable the option as displayed below.

I hope this helps.

Best,

If I uncheck ‘Generate Orthomosaic…’ then the template is removed. If I try and select Ag Multispectral, then the box checks itself and I get this:

Could it be anything to do with this error which I get as soon as I open Pix4D?

[Warning]: Warning w9020: GDAL Error <6> Cannot find coordinate operations from EPSG:4979' to EPSG:4979’

Doesn’t seem to make sense when the source and output crs are the same. EPSG:4979 is WGS84 which is the coordinate system of my images.

Hi Damien,
The reason you are receiving the yellow warning is because less than 20% of the images are geolocated. So there appears be a problem with your drone writing the data to the exif on the images. You may need to explore this option with your hardware. This is why you are seeing the Warning " Cannot find coordinate operations from EPSG:4979' to EPSG:4979’."

As for the Ag Multispectral template, it defaults to Alternative geolocation method. Alternative requires all of the images to be geolocated. Since your images are not geolocated then PIX4Dmapper cannot use this template. You will have to use Standard geolocation which does not require the images to be geolocated.

I thought I would update to 4.7.3 (from 4.6.4) and test with the quarry example data set. No warning about coordinates but that doesn’t work either - same issue.

Hi Damian,
Can you please visit our support page and submit a a ticket?

support.pix4d.com

When you submit can you attach the .p4d file, log file, and 5-10 images. I think this issue is better handled internally.

Will do, thanks Mike