Support Website Contact Support Blog

Pix4Dmapper Pro 4.2.27 Cloud to Desktop: Error Failed to Read Cameras

I’ve been in touch with Pix4D support and it sounds like it is a problem on their end. I recieved the following response from support this morning:

“We have managed to reproduce the issue from our side in multiple machines. Additionally, there are more projects with the same issue and other users experience the same error. That means that it is something related to our processes, rather than your machine. I believe if you try to process the project locally you will not face any issue.
Our investigation up to this point indicates that there is an problem with downloading the results of step 2. However, our developers need some more time to better understand the issue in order to fix it.
Since I cannot provide any time estimation of the fix, I would recommend running all steps of processing locally in order to get the results faster”


Thanks Maria -  I keep all my images on an external hard drive and knew it was seeing them ok because the map view worked.  but not the raycloud.   And this happened after processing locally…and after a software update to  4.2.15    I will try processing

again locally.  Evan

I had the same exact problem as described above and I was able to resolve it fairly easily.

Step 1. With your project closed, move the original input images to a different folder. (These are the images that you input when setting up your project, before you upload to the cloud for processing.)

Step 2. Open your cloud processed project.

Step 3. Pix4D should now prompt you to navigate to the folder where original input images now reside. Select the folder and click okay.

After doing this the issue with “Error: failed to read cameras!” did not occur and I am able to utilize the rayCloud view. I do not know exactly what is going on here, but this did fix the problem. My guess it that is has something to do with having input imagery in multiple folders before cloud processing. I recommend having all input imagery in the same folder.

Hope this helps!


Hi all,

As Logan mentioned, in case you face this error you should always check that all the images are in a single folder. If not, please add all of them in one folder. Additionally, try to copy the .p4d file outside of the results folder, so that you have a folder with all the images, the results folder and the .p4d file.

However, there are cases that even creating this files structure might fail. This is an issue that we are currently investigating in order to make the Pix4D Cloud experience more stable.


We are still having this problem months after the initial bug report.  Are the developers still working on a fix?  Changing the file structure didn’t help.



Hi all,

Please follow the instruction to overcome the problem.

  • Ensure that you have all the images stored in one single folder and the copy of those images doesn’t exist on your computer (the folder is not redundant).
  • Ensure that .p4d file is outside of the Result Folder so that you have a folder with all the images, the results folder and the .p4d file.
  1. Open project.
  2. Pix4Dmapper should prompt you to navigate to the folder where images are located, select the proper folder and click OK.
  3. However, you can still meet yourself with a similar view to this one, where the processing results are still missing.
  4. Open the Result Folder.
  5. Ensure that all the processing files are stored there.
  6. After it, you will be able to see the rayCloud of your project.
  7. Save the project to remain the image path.

Allison in your case, can you check step 5 and let me know if it works for you?



1 Like

Thanks Beata!  It turns out I was wrong, we hadn’t yet moved the images into a single folder when we had this problem, and doing so fixed it, sorry about that!


1 Like


which type of problem is this. and how to solve this?

Hi Tom,

We would need more details to assist in the most efficient way. Could you upload to our OneDrive the following?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The project log file (text file): …\project_name\project_name.log
▸ The project file (.p4d): …\project_name.p4d

Thank you in advance! 

hi beata 

i send you files on your one drive. please check it out

Hi Tom,

I can see that there are 7429 images that you’re processing. Am I right saying that you’re processing them in one bath? It’s not a merged project, right? 

Investigating the error I can say that it appeared after the Keypoints Extraction Process. The keypoints were extracted, however, the information can’t be written into .p4d file. Therefore the errors:

  • no blocks computed,
  • no calibrated cameras
  • error e0046: Processing failed. No calibrated cameras

appeared subsequently. 

My questions:

  • Have you ever experienced a similar problem with any other project?
  • Where did you save the project, on some external drive? Is there enough space? Do you have there
  • edit/write permissions? 


Your NVIDIA driver is outdated. You can download the one for you from NVIDIA website


pix4d merge two dtm values or  not ??? because i split my project 3 parts


Hi Tom,

What do you mean asking whether the Pix4D is merging two DTM values? Did you decide to split this project into three subprojects?


hello beata

yes i decided to split the project into 3 parts. and now i merge two dtm values without using gis?

Hi Tom,

I suppose that you processed each step (Step 1,2,3) in each subproject that you had and now you want to merge DTMs. However, it is not the proper workflow of how you should merge subprojects. Please have a look at our articlehow to merge projects and the video included to learn more about this process. If you have some questions related to this method, you can reach us here.


Hi we are having an issue with a project of ours,
after we run the initial processing with full image scale we get this error:
" [Error]: Failed to read cameras! "

initially the project was in the same folder as the images, later we removed the project and recreated it with the images in a separate folder but the issue remained.

PS We are using Pix4d mapper 4.6.4

Hi Theodore,

Could you please send us the following?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The project log file (text file): …\project_name\project_name.log
▸ The project file (.p4d): …\project_name.p4d

If you want you can upload the files to our OneDrive.


Hi Nikoleta,

Hi Theodore,

I checked your log file and I noticed you were trying to process more than 11000 images.
There are two workarounds I would suggest:

  • You could split the project into subprojects, process Step1. of every subproject, add MTPs in the common areas and then merge them. For more information you can follow the instructions of the articles below:
    How to split a project into subprojects – Support
    How to merge projects – Support

  • The other solution would be to download and install PIX4Dmatic and use your 15-day-trial now.
    PIX4Dmatic is optimized for accurate and fast photogrammetric processing of very large projects, like yours. It is designed to handle and process thousands of images with ease while maintaining survey-grade accuracy. For further imformation:
    PIX4Dmatic – Support

I hope this helps!


A post was merged into an existing topic: Generate Contours in Pix4DMatic