Support Website Contact Support Blog

pix4dmapper.exe File corrupted

I just tried to install the Px4D Mapper software and I got a pop up box stating

“pix4dmapper.exe File corrupted! This program has been manipulated and maybe it’s infected by a virus or cracked. The file won’t work anymore.”

 

Any idea what may be going on here?

 

TIA

Hello Mark,

Did you get the file from the download area? Which version are you trying to install?

Try to download it again as maybe the download was not complete.

In addition to that, the message says that it is infected by a virus or cracked. Did you copy the file from one computer to another? Could it be infected by a virus?

Regards.

Hi Daniel, thank you for your reply.

Yes, the download came from your website and I have now downloaded it twice but I got the same message on both occasions…And no the file wasn’t copied from another computer, as I say it came straight from your website.

i am using a work laptop and we have good anti virus software so I don’t know what to do now.  Meanwhile my trail period is slipping away :frowning:

 

I will uninstall and reinstall and see what happens.  This will be the third time…

Hi again,

This looks like maybe your antivirus software may be interfering with the installation process. What antivirus software do you have installed? Can you try the following to make sure that you have a clean start?

  • First, ensure that there is no current version installed.

1.  In the Search Windows type, type program and select Add or remove programs in the Settings list.
2. Scroll to find Pix4D Desktop and click the application if it exists.
3. Click Uninstall if it exists.

  • After you have ensured that there are no versions installed do the following.

Sometimes, there are leftovers folders. Please check that the files below do not exist: 
1. On the path where Pix4D desktop (Pix4Dmapper) is installed: C:\Program Files\Pix4Dmapper make sure this folder does not exist anymore. If it exists, DELETE this Pix4Dmapper folder.
2.  On the following path:  C:\Users\Your_USERNAME\AppData\Local\pix4d  make sure this folder does not exist anymore. If it exists, DELETE this Pix4Dmapper folder.
3.  C:\Users\YOUR_USERNAME\Documents\pix4dmapper make sure this folder does not exist anymore. If it exists, DELETE this Pix4Dmapper folder. (THIS WILL DELETE ANY EXISTING PROJECTS SO MAKE SURE TO BACK THEM UP INTO A SEPARATE FOLDER)
4.  On windows the search bar type:  and then search for the folder stored in the path: HKEY_CURRENT_USER\Software\pix4d and make sure this folder does not exist anymore. If it exists, DELETE this Pix4Dmapper folder.
5.  Restart the computer. 

  • Download the installer at the link below then temporarily disable your antivirus software for installation. 
  • Install the latest version of Pix4D Desktop using the instructions HERE
  • If possible add Pix4D to the whitelist of trusted programs in your antivirus software. 

If this does not resolve the issue. Please respond with an update and I can help you troubleshoot further.

 

I am having the same issue, with getting a pop-up window saying the “File corrupted!..”
However, I am working at a university and our Tech guy found that the program will work when running under 
Administrative privileges but will not work under my normal user profile. 

Any ideas how to solve this problem? We have tried uninstalling it several times, and the downloads came directly from the website.

We have 2 floating licenses, and we are using version 4.2.27

 

Any help would be greatly appreciated!

Hello John,

If the same file works when you have administrative privileges but not with your profile, I would say that it has nothing to do with the file itself but with your privileges. Maybe you are not allowed to install any software application or you do not have the right to write in some units. There could be many reasons. Please check with the tech guy to see if he can increase your privileges.

Regards.