Pix4D Capture with Inspire 1

I’ve had two failures flying my Inspire 1 with Pix4DCapture.

1.) The Inspire 1 finishes flying before completing the mission, and begins uploading the photos. 

2.) The Inspire 1 flies away instead of carrying out the mission.

In both instances, I have to switch the remote controller to manual mode and abort the missions. 

Is there a way to resolve this?

Hi Robert,

We followed up on these issues by email from the request you sent us.


Do you have any update on your experience? The times I have experienced this was due to ignoring the homepoint on the checklist. I’ve had times when I could not get it to update. Flying the inspire manually would usually reset the home point and stop the issue.

Hi Dustin,

Thank you for sharing your experience.

The maximum distance from the center of the grid to the home point is set to 150 m on both Android and iOS. The home point is actually where the drone is turned on and acquired the GPS signal the first time. This distance is mainly for security reasons, to prevent an accidental launch of a mission when the grid is too far away and it is also limited to prevent connectivity losses. However, this can be discarded.

  • Android: Go to Home screen > Settings > section Advanced > check Enable advanced mode.
  • iOS: Go to Home screen > Grid Mission > Settings icon > set the option Ignore home point to Yes.

Do you mean you experienced a similar behavior of the drone as Robert, and you noticed it only happened when the option Ignore home point on iOS was activated?


Any update on this? I really need to know if I should discontinue using this app. 

In this case, my Inspire 1 was a faulty unit.