Support Website Contact Support Blog

Pix4D Capture Mission generation Failed Parrot

Hello, whe are having a problem with the Parrot Anafi drone and Pix4d Capture.

When we have conneted the drone to the controler and the phone (android), whe can use Pix4 without problem. He reconnizes the drone.

Butt when whe make a Project, and a mission in it, whe want to start the misson, al the thinks are green marked, when whe press start for 3 second he giff the message “Failed to generate Misson” and closed down the misson.

Is some one with this problem? Its just for a few months now.

Have you tried our Pix4Dcapture troubleshooter?

We have the same problem on all our anafies. Please help


Yes whe tried it al. From full reboot off the drone. And alsow a full back to fabric setting from the phone hisself.

I have two successful missions i one project, but then message “Failed to generate Misson” came again on third mission. I didn’t change anything. It were predefined missions, i have only change location, and of course turn off controler.

Yes thats alsow the problem. Its not a problem withs is a constant, what has to do with a wrong setting or something.

Dear Christina

I have got the same problem with Anafi Work.
Please Let me know what is the reason of the failure.

Best Regards

Could you please provide us with the log files:

We experienced the same problem here with at least three different ANAFIs. Already asked users to get log files. But please, check it! It’s obvious Pix4Dcapture is having an issue.

I have experienced countless issues with setting up missons with my anafi as well. I finally got it to work only yo have another issue.

I found that if you saved the mission before trying to fly it, it seems to work. Open the app, choose which flight grid you want, choose the parameters of the mission and elevation, then click the floppy disk icon to save it. Go back to the home screen and into project list, then try to fly the mission and it works. I found when I did not save it first that it would sit on the check list screen and never work.

Like I said I ran into a bigger issue when flying a mission. I started a mission and everything worked fine. My drone got to the end point and just hovered. A notification popped up on my phone and said drone hovering, resume mission or take over manually. I hit resume mission and the time it took me to do that and look up, my drone was gone No where in sight and I was unable to find it. I have flown many practice flights to make sure the app worked and the one time I take it into the field for commercial use, this happens. I have read and heard of many similar “fly off” incidents.

pix4dcapture.log.1.txt (2.1 MB) pix4dcapture.log.2.txt (2.0 MB) pix4dcapture.log.2.txt (2.0 MB) pix4dcapture.log.1.txt (2.1 MB) Pix4Dmapper.log (104.6 KB) pix4dcapture.log (562.8 KB)

I’m attaching some logs. The ones with “.1” or “.2” extension had an “.txt” added in order to be able to upload it here.

Can I send you my log files ?

I see the above link is for android users. Are you able to send one for iPhone?

Thank you all for your feedback.

Our developers’ team confirmed that this is an issue related to a Parrot firmware release. We have notified Parrot about it.

@jbrown I am sorry to hear about the fly away you experienced.

As mentioned here: pix4dcapture - drone lost - #2 by Kapil_Khanal
if you send us the log file (for instructions, please see the above-mentioned community post), we will have a look and try to extract the coordinates.

com.pix4d.pix4dmapper.capture 2021-03-22–12-01-45-301.log (1.2 MB)

I believe this is the log file for the last flight.

Hi @jbrown we need the csv log

flightLog.pdf (263.6 KB)

I could not upload the csv file so I pdf it instead. Please let me know if this works.

@jbrown the last row on your document is the last registered coordinate of the drone. I hope this helps

40.06525 ,-75.4599, 60.96579 (lat, long, alt)

Thank you, this is the location where the drone was last seen. Any information on what happened or why the drone would have flown off?

I got a customer who is having a similar issue, I thought that FW on Parrot caused that issue but once Parrot support opened the log file from the drone we find out that he was using the same FW for 2 months and everything was working fine.

Did you guys had a chance to troubleshoot the issue on your end and see where is the problem?