Support Website Contact Support Blog

Pix4d capture and zenmuse XT don't communicate

Good evening, i’m Italian so sorry for my little english. I tried to fly with a DJI Inspire 1 and a Zenmuse XT thermal camera on Pix4D capture (latest version) on my Samsung Galaxy tab A (2016) and i tried also on an Iphone X. The problem is that when in the setting of Pix4D capture the software read correctly the zenmuse XT (screenshot 1) and the time of the fly increase a lot so i think that it’s correct but when i will start the fly the software don’t communicate with zenmuse XT (screenshot 2) and it take photo such as a normal camera so too fast for the thermal elaboration on Pix4D mapper infact the elaboration is failed 
Why does the software (Pix4D capture) read the zenmuse XT uncorrectly? 
Thank you, 

Alessandro

Hi Alessandro,

If my understanding is correct, the camera is properly triggered (pictures are acquired) but you don’t get proper results as if the overlap you set is not achieved correctly. Is that it?

For iOS, it should be straight forward. You have to select the right camera, XT, with the Inspire 1 in the SETTINGS. You will see that depending on the camera you select (X3, X5 or XT), the flight plan is updated to take into account the camera specifications. The speed of the drone will also be updated to respect the parameters you set (overlap, flight height).

On Android, the camera is automatically recognized as your screenshot is showing. The camera parameters should be taken into account so that the parameters set in your flight plan are respected.

I don’t really understand the second screenshot, what should it show?

In any case, be sure to have Pix4Dcapture and drone firmware latest versions. Is it possible to tell the parameters of your mission (overlap, flight height) and a screenshot of your the project you flew? (In the main menu, tap PROJECT LIST to access it)

Best,

Hi Gael, i’ve been tried with all kind of overlap and flight speed. In the secondo screen i would show you that the application recognizes the camera only in the setting page and not in the flight planner because it shows “Inspire 1” and not "Inspire 1 Zenmuse XT). Thank for your time,

Alessandro

Hi Alessandro,

If you have the opportunity to use the iOS version of Pix4Dcapture, I would suggest you do so. By selecting the good drone and the good camera in the Settings, it should work fine. To confirm that the camera is properly taken into account, look at the telemetry on the right side of the screen when you are on the grid planning menu.

On Android, we would need to investigate a bit more. Would you be able to send us the logs of your tests? Please precise us the time and date you tried to make it work or you flew with this configuration, it will help us. You can find a procedure on how to extract the logs here.

Best,

 

Ok, can you give me an email to send you the logs? thanks

 

Hello Alessandro,

I created a ticket so that you can send the logs there.

Best,