Support Website Contact Support Blog

[Phantom 4 Pro][Pix4Dcapture ios 3.0.1] flies first to home point

This unusual flight path happened after updating to ios pix4D capture  3.0.1

I’m running 04.0602 firmware on the P4P. (I know it’s not the latest)

If I load mission on ground. Fly manually to start point at mission altitude and then start mission, the aircraft turns around and flies back to overhead the home point then turns and tracks back to the start point before it starts the mission.

This does not happen if I launch the mission from the ground with the aircraft stopped.

I have re-booted aircraft, Ipad and app. Tried three different missions with same outcome. 

It only started after the update to 3.0.1.

Is there any way I can rollback to 3.0.0?

Do you have any other suggestions?

Tks,

Mark.

Hi Mark,

If the mission is started once the drone is already in the air, for example, close to the starting point of the mission, the drone should fly directly to the exact position of the first waypoint and not back to the home point.

At the moment there are no other users reporting this issues and it might be related to the specific device/drone/firmware configuration used.

I would recommend making sure that everything is up to date (drone, controller, OS version of the device) and try again. More here: https://support.pix4d.com/hc/en-us/articles/115004119343.  

Best,

Thanks Blaž for the reply,

I have been through the troubleshooting steps previously.

I am running latest iOS on ipad mini, latest Pix4D capture, latest controller, but not latest P4P firmware intentionally.

Can I ask- under what circumstances would Pix4D capture command the aircraft to fly to the home point at mission altitude, when it is not part of the mission?

This particular action has only occurred after updating to Pix4D capture 3.0.1

Is there any way to run an earlier version on iOS?

Thanks,

Mark.

Hi Mark, there is no mission or PIx4Dcapture app setting I am aware of that determines whether or not your drone flies to the home point at mission altitude. Under normal circumstances we expect your drone to fly directly to the first waypoint in the mission, which is represented by Start in Pix4Dcapture mission planning map.

My understanding is that your iPad Mini, DJI controller, and Pix4Dcapture are up to date but that your Phantom 4 Professional does not have the latest drone firmware. To ensure the most stable experience are you willing to update your Phantom 4 Professional’s firmware to the latest version?

I am curious to learn why you have decided not to update your Phantom 4 Professional’s firmware. Any additional information you can share will be greatly appreciated.

Thanks Andrew,

I have done some more troubleshooting.

I tried my iphone that had an older Pix4Dcapture 2.4.0 on it and it worked correctly on my aircraft.

So it appears some aspect of Pix4D that has been changed is affecting it.

After that I updated my P4P to latest FW 05.600 with ipad on iOS 11.2.6 and reinstalled latest Pix4Dcapture 3.2.0 and the same issue presents. I also tried a different ipad which had Pix4D 3.0.1 with same outcome.

This particular issue only appeared after the Pix4Dcapture 3.0.1 update. (3.0.0 was OK) and at the time I had not changed anything else.

I will attach some screen shots from yesterdays test flight.

 Any advice you can provide would be appreciated.

Update 3.8.18. I updated to Pix4Dcapture 3.3.0 and it is the same. Also I got one of my colleagues to test his P4P and reports the same outcome. So it appears I am not the only one experiencing this.

Tks,

Mark.

 

 

Hi Mark,

Thank you for the details provided and the troubleshooting you have done.
I tried to reproduce the behavior you are experimenting, putting myself in similar conditions but without any success so far.

Questions/suggestions:

  • Would it be possible for you to test if the behavior is the same using another mobile device like your iPhone?
  • Is there a particular reason why you operate this way?

I would like to be sure to understand the workflow you are doing here:

  1. You load the mission to the drone.
    What are you doing next? Are you starting the mission and taking manual control straight after or canceling it and flying manually to the point described in your pictures?
  2. You start the mission at this defined location.
  3. The drone is going above the home point keeping the current altitude or the drone goes up or down to reach the mission altitude and then go to the homepoint?

My workflow was the following:

  1. Without loading the mission, flying manually the drone to a specific point.
  2. At this location, loading and starting the mission.
  3. Drone is going up or down to reach the set altitude at its current location and then is heading to its first waypoint.

Best,