Support Website Contact Support Blog

Orthomosaic stitching in lines?

Hi all, I am having an issue with the orthomosaic stitching in lines across the property (not following images). I’m not quite sure what is causing the issue, but I am needing to create a 2d Map.

Any help is greatly appreciated.

Please see screenshot, as file is very large.

Hi @royb4th,

In deed that’s not an expected behavior. Looking at your result, my guess it that your overlap is not sufficient enough.

Could you please share the quality report of your project?

Thanks.
Best

What’s odd, is it doesn’t seem to be missing images, this grid was taken twice with 1419 reference images at an altitude of 400 feet. The quality report seems to stitch everything together correctly, but that does not translate into the orthomosaic.

riversteadtest2_report.pdf (1.6 MB)

I just regenerated the orthomosaic with the same results.

I’m not sure what is causing it not to use the entire image. Those lines are not reflective of entire images, but pieces of images @Pix4D_Alumni_MV

HI royb4th,
Looking at the quality report, it appears that the images in your project may not have had sufficient overlap.


Only 1009 of the 1419 images calibrated and the images that did calibrate produced 17 blocks vs a single block. Multiple blocks are often the result of project images not having sufficient overlap.

Was there significant elevation/height changes across this project? Changes in ground elevation can impact the distance between the Camera/Sensor and the Object being photographed which can impact the Field of View and overlap among adjacent images.

Looking at the processing options listed in the quality report, it appears you selected to process at .5 Image Scale. You may find that processing the data again at 1 Original scale will produce more keypoint matches and a better tiepoint generation. The matching method selected appears to be Free Flight or Terrestrial as well. I suggest using the 3Dmaps processing template and see if that doesn’t provide a better result.

Please let us know if these tips don’t help.

Regards,
Aaron Woods

1 Like

Thanks @Aaron_Woods2 !

I’m trying to generate a 2d map only. I don’t really need the 3d functionality. Would this make a difference?

Thanks!
Roy

Hi Roy,
The Pix4Dmapper algorithm really needs good overlap for the best results. You might find that Pix4Dfields can make a better-looking orthomosaic with less overlap if you are only interested in a 2D output and your images were taken with a nadir orientation and have Geotags.
Aaron Woods

@Aaron_Woods2 I’ll check it out! I guess I was confused because the preview of the orthomosaic was fine on the report, but after rendering didn’t work?

Hi Roy,
Typically, if the Orthomosaic Preview in the Quality report looks good, then you should get reasonable results from Full Processing. I encourage you to process your data again using Full Keypoint image Scale and 3Dmaps template that leverages Aerial Grid or Corridor matching.
Aaron Woods.