Support Website Contact Support Blog

Mosaic error or mismatch in the orthophoto

Hi everyone,

I used the pix4Dmapper to mosaic images from tea garden, it looks well at first check. However, when I zoomed in and check the orthophoto carefully, I found the mosaic error and mismatch as followed:

The GPS of each image was given while processing. 

Does anyone have a similar problem?

Any suggestion will be appreciated.

Please let me know if further information is needed.

Best,

Shu-Yun Chen

Hi Shu-Yun Chen,

Can you send us the Quality Report so we could have more information about your project? :) 

You can find it in:
▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf

To upload the file here you can use file-sharing platform such as We transfer and paste the link here.

Best!

Hi,

Thanks for the reply.

I uploaded the Quality Report and the orthophoto into my dropbox, please check them with the following link: 

https://drive.google.com/open?id=1HMHm6bx5NgimM9B00K3I6LfrotW7QjQq 

 

Best,

Shu-Yun Chen

Hi Shu-Yun

 

By looking the quality report there seems to be a lot of problems with your project:

Only 85% of pictures were calibrated and the software created 7 different blocks which is newer a good sign. Different blocks means that there is some kind of shift somewhere in your project. This is visible in your orthomosaic at your first post. In my opinion this it due to lack of overlap.

What I would suggest to you is if possible go back to field and fly again this time with better overlap.

If it’s not possible you should try to use different settings in step 1.

Hi Jaakko,

Thanks for your suggestion, however, the overlap we used is 85% already… does that mean we should raise the overlap to 90% or above?

Do you have any idea about what kind of settings I should try in step 1?

 

Best,

Shu-Yun 

Hi Shu-Yun

 

The GSD in your projects is under 1 cm which means that you are flying really close to the ground. Is there some reason why you need so detailed orthomosaic? In your case when there is lot of vegetation on the ground and flying altitude so low I would raise the overlap to 90 or even beyond. Personally I hate to go back to the field just because the overlap wasn’t sufficient.

Other solution would be to raise the altitude but this means that you need to go out and fly again.

Try to change “keypoints image scale” to custom and try different setting.

If it’s possible for you to share the whole dataset I could take a look at it.

Hi Jaakko,

The following is the link to the raw data and the GPS position of each image (in the folder “Raw images”).

https://drive.google.com/drive/folders/1HMHm6bx5NgimM9B00K3I6LfrotW7QjQq?usp=sharing 

Besides, we also tried to make the orthophoto from the same raw images with photoScan, the report uploaded in the sharing folder as well (in the folder “Pix4D_question”). It seems no error match of image after the mosaic process.

Thanks a lot for your kindly help!

Best,

Shu-Yun Chen

Hi Shu-Yun

I just downloaded your project and at first look in my opinion it’s obvious that the overlap isn’t 85%. More like 70%. How fast was the drone flying? In corners the overlap is 85% but in straight flight paths it’s less.

I’ll try to process you project and let’s see if I get better results.