No luck using Pix4DMapper with Pix4DCatch images

Just wondering if anyone has suggestions on how to process images captured in Pix4DCatch in Pix4Dmapper? I’m trying to test out Pix4DCatch but cannot use the Cloud feature (I have a perpetual Mapper license but no longer access to Cloud). I have tried multiple projects and haven’t been able to get success in Mapper.

As an example I used Catch to capture images of a shrubbery. I am using a Samsung S21 for Catch.
The initial capture point cloud generated pretty much instantly in Catch looks quite good (image1), however if I export all data and use these images in Mapper very few of the images calibrate and the results of initial processing are horrible (image2) with hardly any point cloud.

Have you tried adding some manual tie points?

Hi Brad,

PIX4Dmapper should be just fine to process PIX4Dcatch projects. I would suspect that the image content is the most likely culprit for the images not calibrating. The initial image you are referring to is points collected and displayed from the time of flight(TOF) sensor during capture and was not processed. This is more for visualization.

Like when capturing large areas of vegetation with a drone, the recommendation would be to back up and include more overlap to help the software tie the images together. From the preview image, it appears you were pretty close to the subject.

Which trigger method were you using for capture? You can find this in the Settings.

Can you please share a dataset if these suggestions were covered in your projects?

Also, we just released an updated version of PIX4Dcatch on the Android platform today, and it is always recommended to update when available. :+1:


I’m having the same issue processing Catch data captured on the iPad Pro in Mapper.
Another old article was suggesting the LiDAR information doesn’t get added to the export.
Not sure this is what you’re experiencing as well.

Hi ctwbim,

Can you describe the issue you are having with processing PIX4Dcatch projects in PIX4Dmapper?

To be clear, PIX4Dcatch exports all the data from a project to include LiDAR data when using capable devices. PIX4Dcloud / PIX4Dcloud Advanced, and PIX4Dmatic, can process this LiDAR data, but PIX4Dmapper can’t.

The LiDAR data can help fill in homogenous regions with little to no texture. While this can be helpful, it generally will not make or break a project. If a dataset is not calibrating, there are likely other issues that should be addressed.


Was this ever resolved? I have a nice ATP cloud in Pix4D Catch from a S22 Ultra, but when I import into Mapper it fails processing every time.

Hi Andrew,

No further information was offered in the past case.

Regarding yours, I am assuming you are referring to the .ply point cloud assembled using the TOF sensor on your phone? This would be different from one that was processed. Are you able to share details from the dataset you are referring to?

Sharing the dataset would be the most efficient way for me to see what is at issue.


To be honest, I don’t have time to trouble shoot Pix4D. Mapper clearly doesn’t work with Pix4Dcatch data, so I’m finding other solutions. We won’t be buying matic AND mapper that’s ridiculous.


I’m sorry to hear your frustration, but wish you all the best. Any processing software can only work with what it is given to process. I was asking to see the data to find what could have caused the process to fail.

PIX4Dmapper works very well with datasets captured with PIX4Dcatch.