Support Website Contact Support Blog

Mosaic editor export error: "failed to run a step!" v2.0.71

I am working in v2.0.71. I tweak my mosaic in the mosaic editor to remove images with cloud shadows and blurry corn rows. When I save and then export the mosaic, the status bar says 'Merging transparent mosaic tiles…failed with error: “failed to run a step!”

I would rather not re-process the entire survey again because it took several hours.

Hi Jacob,
It is a bug in the version 2.0.71 and it also affects 2.0.77. It happens when trying to export the orthomosaic after having edited regions on the orthomosaic.

We are currently investigating this bug but it is difficult to reproduce. Unfortunately we don’t know any workaround for the moment. We will keep you updated.

We are sorry for any inconvenience caused.

Regards,

Thanks for the response. If you would like my log files or anything from this project to help with bugfixing please let me know.

Thank you Jacob. We currently have enough information to investigate this issue. The main problem is that it is difficult to reproduce since it doesn’t seem to happen every time. We are working on it!

Hello…any status updates on when this issue is going to be fixed? I really like 2.0 but this bug is a big deal to us :slight_smile:

1 Like

I just ran into this problem last week as well. I edited most of the mosaic just fine, but the bug appeared close to when I was finishing up. I also have logs, if needed.

Hi all,

We have recently fixed some bugs in the software which should fix this bug in the Mosaic Editor. We still have to make some tests to check if the issue is fixed before releasing the version. If the bug is fixed, the new version should be soon available.

We will keep you updated.

Thank you for your patience!

Regards,

Hello,

We have just released the version 2.0.80 of Pix4Dmapper which should correct this bug. You can download this new version here:

https://mapper.pix4d.com/download/

Let us know if you still experience this bug!

Regards,

Awesome news! Thank you. You guys rock!


Hello, I have just updated pix4d mapper to the version 2.0.80 and this bug still appeared while saving changes in mosaic editor.

Hi Justinas,

If you open a project with 2.0.80 that was previously giving you this error, you first need to click on Reset in the Export section in the Mosaic Editor to reset the tiles.

 

More information: https://support.pix4d.com/hc/en-us/articles/202557529#label3

The bug was affecting the tiles and they were corrupted. By resetting the tile the problem should be fixed.

Could you try to reset the tiles?

Let us know if it works!

Regards,

Thank you very much, I reset the tiles and it worked. Now I can save my changes. Thank you again.

I clicked reset as stated above, but am still getting the “failed to run a step” error.

Hi Wesley,

Are you using the version 2.0.80?

Do you obtain this error with a project that was processed with an older version of Pix4Dmapper? If yes, which version?

Are you able to reproduce the bug with other projects?

Regards,

I am using 2.0.80. I created the project with 2.0 shortly after it was released. This is where I ran into this error. I have not attempted to reproduce the error with another project, as this is currently the only project that I’m working on. I have not yet attempted to recreate the project either, as I have spent a lot of time on the adjustment, tie points, and mosaic editing. This project has also been completed, and I was using it to try out the new features in 2.0.

Hi Wesley,

Processing again step 3 should solve the problem. 

The bug was happening either when clicking on Save or when clicking on Export.

If you clicked on Save then the corrupted tiles are not written on the disk and therefore when you click on Reset it solves the issue.

However, if you clicked on Export and got the error with a previous version of Pix4Dmapper, then the corrupted tiles are written on the disk and when you click on Reset with the version 2.0.80 it does not solve the issue because it is loading the corrupted tiles. In this case the only solution is to process again step 3.

Note that if you drew regions in the Mosaic Editor, processing again step 3 it will remove them and you will have to draw them again.

Regards,

Any insight in when we’ll get the fix for Postflight Terra 3D?
Very helpful improvements made in the mosaic editor by the way.

Ping:)

Hi Mapix Mapix,

The bug should be corrected with the latest version of Postflight, the version 4.0.81.

Have you tried with this version?

Oops, I based my assumption that it wasn’t fixed in Postflight due to it’s release date (24.08.2015 according to senseFlys download link), and your comment at September 11, 2015 08:32. I’ve used that version but only made minimal changes in the mosaic editor, which passed. I will test it more thoroughly further on, sorry about that.
Nice to see Postflight getting bug fixes before even Pix4Dmapper itself;)
Thanx!