Mesh export very inaccurate

I tried to create a 3D model of a bridge using the Mavic 2 pro and this is what I have at the end (images below)

I tried to use less pictures
I tried to use different settings before running
nothing seems to work…
Does someone already had this issue ? Can anyone tell me where the problem comes from ?

Thanks for reading, ask me if you need any details

Dear Louis,

Sorry to hear you have this issue and thanks for reporting it, this is unusual… To try to narrow down the issue, do you see the same problem if you export the mesh as as .obj and export it in a 3rd party software such as MeshLab for example? If you would be ok to share the project we can investigate further. Can you also please let me know which version of Pix4DMatic you are using

Kind Regards


I’ll try to export and see what I get on meshlab, I’m using the 1.47.1 version . If you want to watch the mesh yourself here are 2 links : (pix4dmatic project) (pictures)

Dear @louis.cossart

What you are seeing seem to be artifact due to the software processing very large coordinates.
Looking at your project we could see that this is because the project contains some images with a completely incorrect geotag (located at -2.7°, 0°, in the middle of the ocean) and this is unfortunately resulting in the software picking an incorrect CRS. Processing without these two images with corrupted geotags seems to solve the problem.
I hope this helps you solve your issue.
Kind Regards