Mesh is only one huge blob


I just processed my first large dataset (15 ha) taken with a Mavic 2 Enterprise Advanced and RTK.
Around 1200 images, some needed to be calibrated manually due to complex structures.
The point cloud comes out incredibly well in most areas but the mesh seems to be simply broken.

The green MTP markers show approximately the area that was modeled.

Any ideas where this may come from?


Hi InspecDrone,
Do you mind uploading your quality report so we can take a look at it?

Hi Mike,

thanks for the quick reply, sorry for my delay.
Here is the report. Needed to remove a bit of information.
Pix4D_Report_upload.pdf (1.9 MB)

I tried online processing in Pix4D Cloud also and it came out even worse.
Interestingly DroneDeploy seems totally fine with the data as the customer used our images in his installation and it looks perfect. I really expected more from Pix4D here.


Hi InspecDrone,
Thanks for attaching your quality report. It appears you have some high camera optimization errors. I would suggest enabling All Prior under step 1 processing options. This will force Mapper to trust your camera more than it otherwise would. I would also suggest using Accurate Geolocation and Orientation since you are using an RTK. Mapper will place more weight on the locations.

I also suggest looking close at your MTPs. Most of your points have a pixel errors well above 1. I would suggest marking these at a higher resolution so that the error drops below 1. If you cannot get the error below 1 then I would not use that MTP.

Thanks a lot for the hints! I’ll play with this and hope the results are improving.
Regarding the MTPs I am hoping for better results from step 1 so I do not have to manually calibrate so many cameras.

You might not need MTPs with these processing options. Let us know if you still need assistance.