Support Website Contact Support Blog

Matrice 600 Pro / Zenmuse X5 Image Capture Failure

Hello everyone,

We are having trouble completing our photogrammetry flight missions with our DJI Matrice 600 Pro & Zenmuse X5 using a combination of Pix4Dcapture and Pix4Dmapper. The drone will fly its 3D grid mission, but about 5 minutes in, the camera will stop capturing images, even though Pix4Dcapture still is showing that images are being taken. When the flight mission is set to fast mode, there seems to be no warning and the flight will continue to completion, however most of the photos are missing. When the flight mission is set to safe mode, the drone will return to home without warning, presumably when the camera stops capturing images. When this happened, I checked the drone settings within Pix4Dcapture, and instead of the Zenmuse X5 camera being shown as the default, it shows “Phantom 4 Camera”. When these images are imported into Pix4Dmapper, the captured images look fine with no error images, but usually less than half of the mission is captured. This is a repeated issue that occurs for multiple different 3D grid patterns, both large (28 minutes) and small (7 minutes). Listed below is the troubleshooting steps ran devised from multiple Pix4D support forums. Any help would be greatly appreciated. I have reached out to Pix4D for personal support, but I figured I’d ask here as well.

Troubleshooting Steps Completed:
iPad Mini 5 has latest iOS installed (14.4).
Using latest Pix4Dcapture from App Store
Using two brand new 64gb Sandisk Extreme Plus SD cards
Transferred newest Zenmuse X5 firmware to both SD cards
Created new flight plan in Pix4Dcapture
Ensured Matrice 600 Pro & Zenmuse X5 are set as default drone and camera.
Ensured flight settings can be changed. Tried both Safe and Fast capture modes
Using only a single Master Controller

In DJI GO 4:
Ensured the “Ready to Go (GPS)” message appears
Formatted SD Card within app.
Cleared video cache
Ensured SD card format is listed as JPEG
Checked SD card storage capacity remaining
Force closed DJI GO 4

Opened Pix4Dcapture
Ensured all flight settings were still the same.
Ran project

Hello @seniorcapstonefipr, The behavior you are describing can’t be replicated on our side and has not been reported to us so far. After looking at your log files, it seems like there was some error while capturing the images. The one thing that was different was the default camera model shouldn’t be the Phantom 4 camera. This might be the result of the connection lost to the actual camera. I would suggest you to verify the connection between the camera and the drone. I would also suggest you to monitor the camera feed during the flight to see if you could find anything.