Support Website Contact Support Blog

Matrice 600 Pro with X5 on android "F A P switch not in right position".

I am having an issue with the pre-flight check. I cant take off due to the Flight Mode Switch. It is telling me that it is not in the F position on the controller. I have tried to switch it to the F mode and wait for quite some time, restarting everything with the controller in F mode and nothing seems to be working. Is this a known issue or just me?

   Thanks  

Hi Kyle,

Can you tell me if you are using the Android or iOS version of Pix4Dcapture? Also, are you updated with the latest drone firmware and the latest Pix4Dcapture version?

This problem has been reported once by a user on Android and it seems that it was linked to a DJI firmware update. Indeed the issue came with a firmware update from the user. After having gone all along the troubleshooting steps, the issue was not solved.
I can suggest you go through our basic checks and troubleshooting article to see if it can solve the issue.

Note that the Matrice 600 and Matrice 600 Pro have not been tested on Android with our application and that you will have to select the Matrice 100 in the settings of the app.(you can see the supported drone webpage here). Then we do not officially support it and we can not make any guarantee that you will be able to fly a mission using Pix4Dcapture in your configuration.

on iOS, The Matrice 600 is supported but the Matrice 600 Pro is not supported officially. However, some missions have been flown with the Matrice 600 pro using the iOS version of Pix4Dcapture and then you should be able to fly using the iOS version of Pix4Dcapture in your configuration.

Don’t hesitate to feedback us.

Best,

1 Like

Thank you for getting back to me. 

The drone and Pix4D app are both updated to their current version. I am on Android and figured that was the issue.