Support Website Contact Support Blog

Matrice 210 V2 RTK odd processing results

I’ve recently been mapping with a Matrice 210 V2 RTK with an X5S camera. I have the DJI D-RTK Ground Station tied into my survey control network. When comparing the results against LiDAR I have for the area (my survey matches the LiDAR within 2") there is a continuous elevation offset throughout the project. All of the slopes and ground data match the LiDAR perfectly but the overall surface / dsm / contours / generated points vary on offsets through different projects.

I am using UGCS Ground Control software to capture the Corridor’s imagery.

Has anyone experienced this? I’ve checked my camera settings, double checked that the ground station is showing the correct coordinates through the aircraft. Any help would be greatly appreciated.

Hi Kyle,

It seems that there is some problem with the absolute accuracy of the model, either the vertical datum was erroneously defined or the image geotags are not reliable. In Pix4Dmapper, we recommend using checkpoints to evaluate the absolute accuracy, because the checkpoints are excluded from the georeferencing process.

The second assumption: maybe the issue is not originating from the photogrammetry model, you might want to check the absolute accuracy of the LiDAR model as well.

In what software did you combine both models? Can you share a screenshot with us, to get a better idea of the issue?


Hi Teodora,
Thank you for your response. I’ve finally got it processing accurate results. It turns out to be the camera setting parameters in Pix 4D, I’m not sure if it’s the X5S that is creating the issue with the rolling shutter or what. I have to re-estimate the camera parameters from the EXIF data for each dataset I need to process.

My survey was laid out in WGS-84 UTM 10N : 126W to 120W
The DJI D-RTK v2 unit is utilizing straight WGS84 Datum from what I read.

When I set the project up I add 1.80 m geoid above the ellipsoid to offset the rod height (this could be done in the field as well)

I set the output coordinate system to WGS-84 / UTM Zone 10N : 126W to 120W.

I modified a bunch of camera settings in Step 1. I have attached the quality report parameters for review as I suspect others are possibly having this issue or have worked through it and can inform me on a better way to go about this.

Just to reiterate, I am setting my DJI D-RTK V2 Base up on a known point shot with a Topcon HR and static has been ran through PPP on this point. The Matrice 210 RTK V2 is then flying a corridor route using UGCS as the Ground Control Station.

My new results are within 1" of a known point on the X, Y, Z axis’ with no 3D GCP’s but one MTP being used.

Quality Report:
test 1 426pm 5-15-20 _report.pdf (142.8 KB)

1 Like

It could be that the camera setting were not properly set in the first processing. Especially when dealing with precise image geolocation it’s important that the correct parameters are used.

The X5S camera is included in the Pix4D camera database and I would recommend selecting the FC6520_DJIMFT15mmF1.7ASPH_15.0_5280x3956 model in the image properties editor.