Support Website Contact Support Blog

[iOS] Resume mission after battery warning bugs out

Hi there,

I used Pix4Dcapture on two different iOS tablets on two different drones (DJI Inspire 2 and DJI Matrice 210 RTK). Both drones and both tablets contain the latest firmware and app version respectively. I used the newly implemented battery resume function on both, and it works on both (and I love it btw!).

However, as soon as I receive the low battery warning (25% on one, 30% on the other drone), Pix4Dcapture bugs out. After battery change and resuming the flight, the drones headed to their intended location to resume the project, but pictures are only taken in a random pattern or not at all. The mission plan is broken from this point on and I have to manually create a new flight plan for the remaining area. Again, this happens only, but all the time, after I receive the first battery warning. It works perfectly when I pause the flight before the warning. I can reproduce this in all our flights.

Hi Ekrem, Nathan and Soil,

Could you please upload the .log files to see if this is an issue on our side or there is something unexpected going on after the battery warning is triggered. Make sure to indicate the date and hour of the mission so we are able to investigate the corresponding events in the file. More information here: (Android, iOS) How to extract the log files.

@Nathan and @Soil, could you confirm that you received the battery warning before clicking the Pause button? Did you maybe have the chance to try the “It works perfectly when I pause the flight before the warning” workflow? Do you experience the same issue?

As a side note, gaps in the image acquisition can happen because of connection loss with the Fast mode. To know if the drone regularly took pictures, we suggest that you open Pix4D Desktop on your computer and import the images that were saved onto the drone (SD card or internal memory). The images have accurate coordinates but not the icon on the Map view of the app.

Best,

The drone actually returned to home automatically.  I think I paused the mission when it started coming back to me.

The images have already been turned into a map using another mapping service.  All the photos that were actually taken worked.

 

Here’s the screenshot again, I’ll work on getting the logs.

@Blaž: just uploaded it with a readme. Unfortunately I have access only to our own drones’ log file, not to the other one I had the same issue with two weeks ago. But as I said, I had the exact same issue on two different drones: pausing before the battery warning and everything works just fine, pausing after the battery warning and the mission plan bugs out (drone is returning to the last position and continues the flight pattern, but pics are not taken at all or very unregularly).

I uploaded the log file and a readme, and a folder of all my log files, which you can disregard.

To clarify:

I have the aircraft set to warn me when battery life has dropped to 30%.  The warning I received at 30% was the RC beeping.  At 20% of battery life, the aircraft will return-to-home automatically, which I suspect is what occurred in this case.  I do not recall receiving a low battery warning from the Pix4D app.

 

Thank you for uploading the .logs.

We forward them to the developers in order to have a look if they can find the cause of the issue. 

At the moment we would like to request more files in order to continue the investigation. You will find the instructions here: (Android, iOS) How to extract the log files. Just to clarify, the link was recently updated with additional instructions for Mission00001/mission.pix4dcapture-mission and flightLog.csv files. 

Hello

How can I upload or send my log files in here? There is no " add file" option.

OK got it. I uploaded my files to comminity users.

 

 

Yes I have the same issue using IOS tablet. Paused mission for low battery and returned home. swapped battery and erratic picture capture started. Excatly like image from ayhan çamurcu above. This is the reason I stopped using Pix4D capture. I’m digging into my old logs to see if you can find them for upload.

@Ekrem, Nathan, Tim, Ayhan, and John, and all, thank you for your patience and contribution to the investigation.

I am happy to report the team responsible for the investigation has identified what is causing your multi-battery missions to fail after landing and changing the battery. I cannot guarantee that the bug will be patched in the next version of Pix4Dcapture, or estimate when the bug will be patched, but I can assure you that the bug is under consideration.

In the meantime, the best way to ensure that you do not experience a similar behavior is to fly a Grid or Double Grid because our understanding is that the behavior only affects Polygon missions.

Thank you for your understanding.

It might help you know that. I did not have any problems with the first two flights with the double battery. The problem shown in the picture was in the third flight mission.

Have tested IOS and after battery exchange it resumed mission but no pictures at all were taken.

@Ayhan, thank you for sharing additional information about your experience.

@Adriano, please consider flying a Grid Mission to ensure that you do not experience the same behavior. You can learn more about the latest status of the investigation in my previous comment.

If your mission works a lot better as a polygon, which most of mine are, there is another workaround for this issue.  

Fly your mission as a polygon, and when the battery is low you can pause the mission and replace the battery.  Remember where your last pictures were taken, and open the mission as a new mission and resize your area to only fly what you haven’t flown yet.  This could be cumbersome if you will need to use several batteries for one mission, but if you use the grid mission for something that’s not rectangular, you’ll fly a lot larger area than you need, which is not convenient either.

The resume feature on iOS, just updated a few days ago, solves all of that by allowing the pilot to pause/change battery/resume.  I just went out and flew a quick mission with 3 battery changes and it worked perfectly taking all the appropriate pictures.  The only minor issue I had was 1 of 2 times the “Go Home” after pausing set it to land immediately instead of getting nearby to home.  Personally I always land manually so that isn’t an issue for me really.

BTW, even force quitting the app still gave me the correct resume when going back into Pix4Dcapture.  Now if they could only fix the Custom Camera trigger time because it sets up the flying the same for 20% overlap to 90% overlap…

Hi Adam Jordan,

Thank you for your feedback.

About the issue you are reporting with the custom camera trigger time, is it possible for you to be a bit more specific? What did you notice?
From my understanding, even if you are changing the overlap percentage, the drone will fly at the same speed and then the overlap desired is not achieved. Am I right?
Also, I would suggest you to create a new post if possible so that the follow-up of the issue you have seen is easier to do.

Gaël

I have more details on the flight speed bug in a support ticket already. Quite simply the custom camera usage makes the front overlap % slider useless as well as the trigger time having no effect on drone speed.

@Adam Jordan, the issue is currently under investigations. We will update as soon as possible on the community threadand by answering your ticket.

Best,

Thanks

Hi, is the problem fixed? Can we fly using multiple batteries?

Hi Ayhan,

Yes, this big has been fixed and multi-battery flights can be done on both iOS and Android versions of Pix4Dcapture.
You can have a look at our procedure on how to operate multi-battery flights here.

Best,