Support Website Contact Support Blog

Importing FARO scene data

I have data from FARO Scene and I can’t output the data as a .las I exported the data as an XYZ text file and converted the file to .las using CloudCompare. Pix4D survey won’t import the LAS file saying it’s an unkown LAS coordinate system. Any ideas on import strategies?

Hi mate,
try to convert your data with Lastools. Sometimes when you export to LAS with CloudCompare, some data is lost (ASPRS LAS formats).

Later, to give a coordinate system to your pointcloud, use las2las, example:

C:\LAStools\bin\las2las.exe -i C:\pathToPointcloud\pointcloud.las -epsg 25830

Then, try to import :wink:

2 Likes

@michael.bauer, when importing a external point cloud the coordinate system information needs to be written in the .las file.

If you are trying to import the FARO point cloud in an existing project that was previously created using the Pix4Dmapper project, then the import is still possible. Just make sure that the coordinates of the external point cloud are in the same coordinate system as specified in the Pix4Dmapper project.

If you are importing an external point cloud in an empty project, then you need to make sure the coordinate system is written directly in the .las file. Check the workaround proposed by @joan.cano and let us know how it goes.

Best

So, first Thank You @joan.cano the suggestion worked like a charm.

I was able to take point clouds exported from CC from different sources and run them through LASTools and get a file that would import into survey. I am currently working on ensuring the coordinate systems are compatible between the various models. So the first hurdle has been jumped…

Thank you again.

2 Likes

What if your point cloud from Scene doesnt have a coordinate system assigned to it but the Pix4d project does? Will the lidar point cloud still import and potentially adopt the coordinate system of the pix4d project?

@Hayden_Fischer, correct, if the external point cloud does not have a coordinate system assigned then the coordinate system of the Pix4Dmapper project will be proposed.

To do so, click Import anyway during the import of the external point cloud:

I have done that. It starts an import but nothing ever shows up in Survey. The point clouds from p4d show up fine but nothing from the imported files. No layer or point cloud is added to the project when it finishes upload. It says it is creating the BPC, which I can find, but I cannot do anything with that, as far as I can tell. Any suggestions? Thanks

I uploaded the files you wanted. I have tried to import each of those point clouds separately, with no luck. I can upload the point cloud from pix4dmapper no problem. Only when attempting to bring in the lidar point cloud. I have also uploaded a couple of the .bpc files that have been created. Let me know what else you will need from me. Thank you

@Hayden_Fischer, I had a look at the files and was able to import them into existing Pix4Dmapper project.
The imported external point cloud appeared in the list of point clouds but was not visible in the 3D view. I checked the file in CloudCompare and noticed that all points are in one line and that the point cloud is probably wrongly structured.

Do you have an alternative project you can give it a try with?

Yes, that was the issue. The points were in fact appearing in Pix4Dsurvey, they were just almost invisible. Thank you!