Support Website Contact Support Blog

GCP's applied but exports don't carry the coordinates from project

I have imported some GCP’s and have re-optimized and done the whole shebang. In Pix4d everything is where it is supposed to be. the coordinates in the lower right corner are showing the right numbers. When I export out the .las and import it into anything else the coordinates are no longer correct.

This project has an arbitrary system, but I have even translated it into the Utah State Plane system and still the export files do not coincide.



Right click on the point cloud. Export Point Cloud, Then you should be able to chose any of those formats. I’ve only used XYZ though. What program are you trying to import it into? Email me @ if you need some more help. I’m in Utah as well.

So, I guess I should clarify. I have found that I can export an XYZ and the exported file seems to stay in the correct coordinate system. When I export an .LAS file it seems to try and force it into a metric system or something. I have been bringing in the exported point cloud to Trimble Business Center and also AutoCad with the same results. The trouble I am having is that I have a program to  be able to thin the point cloud after i have exported it but it only seems to work with the LAS and not the XYZ. I am finding that LAS might always have to be metric, because even in Trimble Business Center if I attempt to export a point cloud to an LAS it only gives me the option for a metric file.


So, that is my issue. I can export the XYZ just fine, but then I cant thin the cloud enough to have it be usable (100 MB plus file when made into a surface.) But I can thin an exported LAS file but the coordinate system does not come across. 


The images are taken and georeferenced with the UTM system, and in Pix4d I am setting the output to both State Plane and Arbitrary systems, both of which are US FT.

Hi all,

About the thinning option:

I have added this idea to our suggestion list.The user should be able to export a point cloud based on a desired file size or number of points. Our Product Development team will consider it for future version of the software.

About the las file:

When we import it in Global Mapper, we get the coordinates in feet. All measurements are also in feet. To get the measurements in feet, we had to select the measurements’ units.

Trimble Business Center and  AutoCAD might also have an option that permits you to define the units. I would recommend you to contact their support. Let us know about your findings!

Best regards!