Support Website Contact Support Blog

Experiences with Phantom 4 V2 and P4D

There was a really long thread going on P4D not working for P4P V2, but it is for android, at least, now. (why does P4D have to be spelled so close to P4P?..)

There seem to be some bugs though, so I thought to post what I saw.

The first was the app did not seem to save my flight plan. I deleted the project and made a new one, then it started working. The policy I use now is to save the flight plan, close it, and re-open to see its in the right spot. It then behaves if in right spot.

The second issue is how do I take off manually, then tell P4D to start? I got a message the drone was in manual flight when I tried. I had DJI Go closed, as I always do before opening P4D. I could only get things to run if I did the whole flight starting from a landed position.

I can say it worked perfect using my S8 phone, once it flew. That is nice, and I trust the app now, in case anyone is looking for guinea pig opinions.

Any other bugs/oddities going on out there?