Support Website Contact Support Blog

Error Loading project

I set all the processing option and started processing images but during quality report generation phase error message pops up and pix4D stops responding and closes.

If i load the very same project the following error occur

[UI]: Open Project clicked.

[Error]: XML file validation failed with current XSD

Please suggest the solution to this problem. Thank you in advance.

Dear Kapil

Please send us the .p4d file (by hitting the Submit a request button at the top of this page). It would be helpful if you added a link to this forum post. We will then investigate what the issue is with this particular .p4d file. 

Best regards,

Hi,

I’m having a similar issue trying to re-open projects after a PC crash. It has happened to 2 projects files, but ONLY after each had experienced a “blue screen” during processing - all other projects still open fine.

I’ve attached a screen shot of what I get when I’m trying to reopen the project.

I really need a way to get back into these project files.

Similar problem here, started getting this message after attempting to open any old or new project. PC didn’t crash or anything. Need help!

[Error]: Error e0400b: Cannot open project C:\Users\RUBEBACA\Documents/pix4dmapper/tutorials/guided_tour/guided_tour.p4d. Invalid format.

Hey Timothy, hey Jim,

With which version did you create your project? and which version are you trying to open it now?

If your project was created in a very old version, then you need to open the project with an intermediate version to make the change progressive and ensure the .p4d compatibility, since the .p4d files are not retrocompatible. 
For example, if you created a project with 1.1.45 then you cannot open it right away in 2.1.61, you should open it in 2.0.104 and then in 2.1.61.
Also you cannot go back from 2.1 to 2.0 for instance, if your project was created in a more recent version. 

@Timothy, were you running the project when your computer crashed? 

Best Regards,

Yes, the project was processing when the computer crashed.

And the projects were created in the same version that I tried to reopen them with. I got the error immediately after the computer restarted following the crash.

Hi Timothy,

Which version are you using to create and process the project?
Also could you maybe provide details about when and how the crash happened (which step, any error message before, etc.)?

Do you mind sharing with us:

  • The project log file: …\Project_name\Project_name.txt
  • The .p4d file: …\Project_name.pd4

You can upload them here: https://www.dropbox.com/request/LadB6nPokleQxvBzoIhf

Regards,

Same here, it just happened?

I merged 96 small projects, photos acquired by eBee so each project is small, total number of photos is just over 10,000.

After merging, over 60% of my calibration was gone even those each individual project was nicely calibrated over 95 of the images. So I decided to “Reoptimize and rematch” ran for 12 hours, then froze after a completion status and asked me to generate report if I wanted. But I  could not generate report as the whole PC froze. So I decided to hard reboot. Then when I opened the project again I got the error as shown below.

I then decided to go into the file itself (project file) and double click to open it, same error. Has anyone found a solution please? Pix4D Support, I see no more comments after July 27, 2016.

 

Now, the error shown here happens after updating from 2.1.61 which was sued  in the post above, to v 2.2. Does it mean juts between two successive versions project files become invalid?

 

 

Clarence

This is now the nightmare! It is just insane!

 

I have got 96 mini projects, every flight. Are you are saying this???

 

 

Hi Clarence,

It seems like you are in touch with my Support colleague Marili.
We discussed this case and will follow up directly via email to solve the problem.

Regards,

I’m having the same issue when trying to open older files. I think there should be a way of converting files from every older version if you are in the latest Pix4D version.

I also didn’t find any way to download older Pix4D versions. Is this possible?

Thank you

Hi Jose,

This is the usual retro non-compatibility issue explained by my colleague above.
You are probably trying to open a project with Pix4Dmapper version A whereas this project was previously processed (or just opened) with Pix4Dmapper version B. The problem is that A < B.

Therefore, to open the project you can only use version B.
Unless you did a backup and then it possible to open with version A the appropriate .p4d file. The backup .p4d file is the project file that can be open with the latest version of the software. The other .p4d file remains in the previous version.

Could you tell the version numbers corresponding to A and B for this specific project?

You can find the previous Pix4Dmapper 2.1.61 here: https://mapper.pix4d.com/download/

Regards,

Hello, I am having the “invalid format” issue as well. The problem is, it is with 2 different projects that I just processed with the same exact version of pix4d that I am currently using to open it. (Project was processed today, closed project, now it says invalid format of the .p4d file)

 

Very frustrating, any idea how to resolve this?

Hi Jason,

Which version of Pix4Dmapper are you currently using?
Also which steps did you process for these two projects?
After closing, did you perhaps move them?

Could you please provide us so that we can investigate in details:

  • The project log file: …\Project_name\Project_name.txt
  • The .p4d file: …\Project_name.pd4

You can upload the files for both projects to our Dropbox if you need: https://www.dropbox.com/request/GbvozGaiu4usSnmlSxWL

Regards,

Hi,

 

I’ve uploaded the requested files. I used the default settings for processing with the Parrot Sequoia. Pix4D Mapper version is 2.2.25

Having the same problem with Beta 3.0.7. I’ve emailed the log and p4d files to support 

hi, i have similar problem, ERROR e0400e, when finish any proyect and close the software, open pix4d whit the  same proyect and always see the error, my version is 2.1.61, any idea how can fix that???

Certainly submit a request, but in my case it was identified as a bug that occurred because the project had been upgraded. Open the P4D project file in notepad (I use NotePad++ instead) and search for the indexDownsamplingMethod tag. Changing the contents to Gauss worked in my case, though, as I said before, send in a support request because your problem may be different.

As a possible workaround, create a new project and then compare the P4D file from the new project with the old. Tags not in the new file will cause problems as can invalid values but I don’t know the complete domain of all valid values for all tags, so YMMV.

I have 5 projects that will not open right now due to this error as well. The were all processed same version, same laptop.