Support Website Contact Support Blog

Error e0706c: Could not authenticate. Check your internet connection. Failure:SSL handshake failed.

We are having a similar issues. It appears to be related to SSL decryption that is going on, on our enterprise firewall… We have excluded *.cloud.pix4d.com that does not work.  Yet we had some success when we excluded the destination IP ,54.86.92.129 from SSL decryption is worked . I am concerned , the application appears to be cloud based and that IP address could change . Could some one provide more information ?Err

Hi,

There is this kb article: https://support.pix4d.com/hc/en-us/articles/202561139-Error-Network-error-Please-check-your-internet-connection-SSL-handshake-failed- 

In your case, are you sure that *.cloud.pix4d.com also exclude cloud.pix4d.com? Can you configure your firewall to trust the certificates provided in the above article instead of adding an exception?

 

Best regards,

Olivier

Hi,

I am using the latest version of Pix4D 4.1.25 on my desktop. I have tried all the solutions given in all the 3 threads. Even i turned off my firewall, installed all the certificates. Still i am getting the same error.

Error e0706c: Could not authenticate. Check your internet connection. Failure: SSL handshake failed.

Please help me as my entire month subscription has wasted just because i am unable to login.