Support Website Contact Support Blog

Error: Cluster Generator: Not Enough Initial Valid Cameras

Generating an orthomosaic of a reef as obtained via UAS image capture, all 322 images are calibrated, there are very few tie points, and when I try to run step2 and when I uncheck step 2 to only run step 3 I keep getting the following errors.

[Processing]: Generating clusters
[Error]: ClusterGenerator: Not enough initial valid cameras!
[Error]: Generating clusters failed!
[Error]: >>>Generating clusters<<< failed with error (failed to run a step!)!
[Error]: >>>Generating clusters<<< failed with error (failed to run a step!)!
[Warning]: GroupProcessing: Failed to generate cluster, skipping cluster
[Error]: Processing group group1 failed!
[Error]: >>>Processing group group1<<< failed with error (failed to run a step!)!
[Error]: >>>Processing group group1<<< failed with error (failed to run a step!)!
[Error]: Dense Processing failed!

It says my .log file is over the 4mb limit, is there any other way I could get it to you to diagnose?

Hello,

Could you please share with us a copy of your quality report and log file?
You can find your PDF quality report by following this directory: \project_name\1_initial\report\project_name_report.pdf.

You can find your .txt log file in the directory here: project_name\project_name.log .
Please upload them here and let me know when upload has finished.

Best,

Docs uploaded.

Hi,

Thank you for sharing the files with us.
I noticed that Keypoints Image scale is set to double (2). Your images are quite big so I would not suggest that to use the Double option. Instead try to use 1 or 1/2.
May I ask if you have tried processing with the 3D Maps template?
If not my suggestion would be to try with the 3D Maps template first and enable as well the Use Geometrically Verified Matching option as shown below and process again:


and

If results are not good please share with us the updated quality report.

Best,

I have uploaded an updated quality report to the folder of when I process the image at 1/2 keypoint image scale. I am unable to generate a pdf report and have screenshotted it.

Using the 3D Maps template and enabling “Use Geometrically Verified Matching” option it says the processing has failed due to camera calibration. It gives a failed quality report.

Thank you.

After changing the keypoint scales it also failed to write any tie points. Is this an issue with inadequate imagery being used?

Hi,

In the quality report you uploaded you are using an advanced option for the matching image pairs:

Can you please select the following?

  • Keypoints Image Scale set to 1
  • Select Aerial Grid and enable Use Geometrically Verified Matching option
  • Select All as Internal Parameters Optimization


Uploading: 2022-01-12_10h22_38.jpg…

Let me know how it goes and upload the new quality report and log file if possible.

Best,

Updated quality report uploaded. Thank you!

Hi,

Thanks a lot for uploading the file. Can you also upload the dataset?
Please zip the folder with the images before uploading.
Let me know when the upload has finished.

Best,