Support Website Contact Support Blog

Drone never returned, while doing a Pix4D mission

Hi!

A few days ago I was mapping a quite large area in the alps. Pix4D crashed in every mission, but at least the pictures were taken by the drone. Doing the last mission (after 2 days of flying), suddenly the drone lost connection and never returned. Everything was updated and worked properly with the Dji go app. The drone was a M2P and I tried 2 different cellphones.

Any ideas? 

Best regards Josef Baumgartner.

Hi Josef,

I am sorry to hear about this bad experience. Did you have the chance to interrupt the mission or take back manual control as it is explained in our article on our Knowledge Base? In a general way, Pix4Dcapture is acting as a third-party application and can not override the fail-safe behavior of the drone. In case of connection loss, It should have followed the fail-safe behavior defined in the drone manufacturer application.

Also, I would have several questions to try to understand what happened:

  • Are you using the iOS or Android version of Pix4Dcapture?
  • When you report that Pix4Dcapture was crashing every mission before you had the fly away, what was the exact behavior of the application? was it lagging? Was it stopping?
  • Did you find back the drone?
  • Were you in a place where interferences could have occurred or a difficult terrain that could have lead to a connection loss?
  • If the terrain was difficult, was the flight height enough so that the drone will not run into something during its flight? Indeed there is no terrain awareness feature implemented in Pix4Dcapture.

Best regards,